Bug 1247220 - Docker packages are missing for i686 and armv7hl architectures
Docker packages are missing for i686 and armv7hl architectures
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: docker (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lokesh Mandvekar
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F23AlphaBlocker
  Show dependency treegraph
 
Reported: 2015-07-27 11:00 EDT by Stephen Gallagher
Modified: 2015-07-31 17:04 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-31 17:04:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gallagher 2015-07-27 11:00:26 EDT
Description of problem:
Docker in Fedora 22 and earlier has been built for x86_64, i686 and armv7hl. In Fedora 23, Docker 1.8.0 is only building on x86_64. This is causing numerous issues in Fedora, from broken dependencies for the Cockpit project all the way to compose failures of Fedora Server on i686 and armv7hl.

Version-Release number of selected component (if applicable):
docker-1.8.0-4.git0d8fd7c.fc23

How reproducible:
Every time

Steps to Reproduce:
1. Attempt to install the cockpit-docker package on an i686 Fedora 23 system.

Actual results:
Docker does not exist and the package cannot be installed.

Expected results:
Docker should be present.

Additional info:
Comment 1 Fedora Blocker Bugs Application 2015-07-27 11:03:32 EDT
Proposed as a Blocker for 23-alpha by Fedora user sgallagh using the blocker tracking app because:

 "All release-blocking images must boot in their supported configurations."

From an IRC discussion with Dennis Gilmore: "(07:19:55 AM) dgilmore: [13:17:17] Unable to create appliance : Failed to build transaction : cockpit-docker-0.67-1.fc23.armv7hl requires docker >= 1.3.0"

Can't compose Fedora Server 23 properly because it requires the @container-management package group.
Comment 2 Adam Williamson 2015-07-27 12:28:05 EDT
Discussed at 2015-07-27 blocker review meeting: http://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-07-27/f23-blocker-review.2015-07-27-16.00.log.txt . Accepted as an Alpha blocker on the basis that it blocks compose of release-blocking i686 and ARM server images.
Comment 3 Matthew Heon 2015-07-27 15:12:51 EDT
The x86 and ARM builds were disabled due to issues with Docker's implementation of Seccomp, which does not support these architectures and causes build failures.

The long-term fix to this is https://github.com/opencontainers/runc/pull/70 which will convert Seccomp support to use an architecture-agnostic backend. However, these changes are held up in review upstream.

I've added a patch to remove Seccomp from the build entirely. While the feature is available in the libcontainer backend, Docker itself is not aware of it and does not take advantage of it. This should resolve the issue until the proper fix makes its way upstream.

Waiting for Lokesh to trigger a build to see if the patch resolved the issue.
Comment 4 Lokesh Mandvekar 2015-07-28 11:03:46 EDT
fixed here: http://koji.fedoraproject.org/koji/taskinfo?taskID=10511190
Comment 5 Adam Williamson 2015-07-31 16:26:38 EDT
We need an actual Bodhi update for this, not just a Koji build. Thanks!
Comment 6 Lokesh Mandvekar 2015-07-31 16:30:54 EDT
Has bodhi been turned on for this yet? When I try to 'fedpkg update' it tells me it's not been tagged as an update candidate.
Comment 7 Adam Williamson 2015-07-31 16:59:16 EDT
Bodhi has been turned on for F23, but if you did your build at a particularly unfortunate time it may not have got the tag. You can tag it manually:

koji tag-build f23-updates-candidate (NVR)

should do it.
Comment 8 Adam Williamson 2015-07-31 17:01:33 EDT
Oh, huh, actually - it somehow got tagged f23 and is in the F23 tree. So I believe we can close it, assuming the fix works. Let's mark it ON_QA and check with releng. No further action needed on your part unless the fix is bad, thanks!
Comment 9 Adam Williamson 2015-07-31 17:04:58 EDT
There is definitely a docker-1.7.x package in the current 23 tree for i686 and ARM, so I'm gonna go ahead and close it.

Note You need to log in before you can comment on or make changes to this bug.