Bug 124724 - 3ware 9500 drivers not in kernel
3ware 9500 drivers not in kernel
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-28 16:38 EDT by Peter Maas
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-29 04:13:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
3ware 9500S Makefile (2.6) (222 bytes, text/plain)
2004-05-28 16:41 EDT, Peter Maas
no flags Details
3ware 9500S Driver Source (73.55 KB, text/plain)
2004-05-28 16:42 EDT, Peter Maas
no flags Details
3ware 9500S Header Source (31.03 KB, text/plain)
2004-05-28 16:42 EDT, Peter Maas
no flags Details
3ware 9500S Header Firmware Source (zip) (312.85 KB, application/octet-stream)
2004-05-28 16:46 EDT, Peter Maas
no flags Details

  None (edit)
Description Peter Maas 2004-05-28 16:38:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET 
CLR 1.1.4322)

Description of problem:
Fedora core 2 does not include the 3ware 9500 series drivers, the 
8500 series drivers and below do not work with this card. 3ware has 
released GNU GPL drivers with this card.

The FC2 setup attempts to load the 3w-xxxx series driver which does 
not detect the controller.

FC2 cannot be installed if the 3ware card is the only disk subsystem 
on the machine at the time of install. In my case it is optimal to 
install the operating system on the raid array in case of disk 
failure.

I am including the 3ware 9500 series source from 3ware without 
modification.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Attempt to install FC2 on 3ware controller as boot device.

    

Actual Results:  3ware 9500 controller is not detected.

Additional info:
Comment 1 Peter Maas 2004-05-28 16:41:06 EDT
Created attachment 100681 [details]
3ware 9500S Makefile (2.6)

3ware 9500S Makefile
Comment 2 Peter Maas 2004-05-28 16:42:17 EDT
Created attachment 100682 [details]
3ware 9500S Driver Source

3ware 9500S Driver Source
Comment 3 Peter Maas 2004-05-28 16:42:47 EDT
Created attachment 100683 [details]
3ware 9500S Header Source

3ware 9500S Header Source
Comment 4 Peter Maas 2004-05-28 16:46:05 EDT
Created attachment 100684 [details]
3ware 9500S Header Firmware Source (zip)

3ware 9500S Header Firmware Source (sorry, had to compress, too large to post
other wise.)
Comment 5 Peter Maas 2004-05-28 17:03:39 EDT
I was just informed that 2.6.7-rc1 may have updated drivers for this 
device... the change log notes this

<aradford@amcc.com>
[PATCH] 3ware driver update
	
This patch includes the following driver changes:
	
1.26.00.038 - Roll driver minor version to 26 to denote kernel 2.6.
Add support for cmds_per_lun module parameter.
1.26.00.039 - Fix bug in tw_chrdev_ioctl() polling code.
Fix data_buffer_length usage in tw_chrdev_ioctl().
Update contact information.
Comment 6 Peter Maas 2004-05-28 17:51:30 EDT
after reviewing the code for vanilla kernel 2.6.7-rc1-bk5, it does 
not appear the 9500 series drivers have been commited to the kernel 
yet.
Comment 7 Arjan van de Ven 2004-05-29 04:13:00 EDT
3ware really needs to get these upstream first...
Comment 8 Dax Kelson 2004-09-24 12:48:42 EDT
The 3w-9xxx driver is in the latest errata kernel for FC2 (maybe even
a few errata kernels back too).

I built a custom boot.iso that allowed me to install FC2, it was more
complicated than just making a driver disk (which I tried first),
because of a bug in the pcitable file of FC2.
Comment 9 Nate Faerber 2004-12-08 22:02:05 EST
Can I see that boot.iso?  Once FC2 gets installed, do you install an
updated kernel before the first reboot so you can boot the 3ware?

Do driver disks actually work in FC2?  I have not had any success
getting them to work.

Note You need to log in before you can comment on or make changes to this bug.