Bug 1247245 - Can't create VM instances as Project user with Admin privs or Admin as a member
Can't create VM instances as Project user with Admin privs or Admin as a member
Status: CLOSED DUPLICATE of bug 1236620
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity high
: ---
: 7.0 (Kilo)
Assigned To: Matthias Runge
Ido Ovadia
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-27 11:54 EDT by Audra Cooper
Modified: 2015-08-04 10:12 EDT (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-04 09:48:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Show's adding the admin user and admin privs, also error that project isn't specified. (90.74 KB, application/zip)
2015-07-27 11:54 EDT, Audra Cooper
no flags Details

  None (edit)
Description Audra Cooper 2015-07-27 11:54:26 EDT
Created attachment 1056667 [details]
Show's adding the admin user and admin privs, also error that project isn't specified.

Description of problem:
Currently to be able to create VM instances, you must be logged into Horizon under a project as a User, not Admin.  If that User has Admin privs or if you have the Admin user as a member, you cannot create an instance.  You get an error that a project must be provided.  

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. In Horizon, log in as Admin and create a new project, testproj
2. Create a new user, testuser as an admin
3. Log in as testuser and try to create an instance

Actual results:
Get error that a project must be specified, yet there is no project in the dropdown list and it won't allow you to enter anything in the project field.

Expected results:
Should be able to create an instance

Additional info:
Comment 3 Martin Magr 2015-07-31 09:31:47 EDT
I'm unable to reproduce this. When I add created user to created project, I am able to select project in form and hence spawn instance as created user.
Comment 4 arkady kanevsky 2015-07-31 09:38:26 EDT
Let Benny deploy latest OSP7 using automation on futureville stamp and see if he can reproduce it. If yes, then Martin can access futureville stamp to see what is going on.
Comment 5 Mike Orazi 2015-07-31 10:28:31 EDT
I had a similar report from Ido re: reproducibility.  If we are able to reproduce it in the futureville stamp let's start gathering config differences and see what we find.
Comment 6 Ido Ovadia 2015-08-02 10:29:47 EDT
(In reply to Mike Orazi from comment #5)
> I had a similar report from Ido re: reproducibility.  If we are able to
> reproduce it in the futureville stamp let's start gathering config
> differences and see what we find.

I'm unable to reproduce this bug. 
I tested it on last two builds
Comment 8 Matthias Runge 2015-08-04 09:46:46 EDT
Possible duplicate of this: https://bugzilla.redhat.com/show_bug.cgi?id=1236620
Comment 9 Matthias Runge 2015-08-04 09:48:05 EDT

*** This bug has been marked as a duplicate of bug 1236620 ***

Note You need to log in before you can comment on or make changes to this bug.