Bug 124727 - dri disabled
dri disabled
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-28 16:55 EDT by Malcolm Amir Hussain-Gambles
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-01 05:03:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Malcolm Amir Hussain-Gambles 2004-05-28 16:55:52 EDT
Description of problem:
getting dri disabled

Version-Release number of selected component (if applicable):
6.7.0-2

How reproducible:
always

Steps to Reproduce:
1.run X
2. glxinfo
3.
  
Actual results:
dri disabled

Expected results:
dri enabled

Additional info:

This has been tried on a fujistu ( i686 via savage) laptop
and my home pc (athlon amd/radeon 9800)
both refuse to enable dri without any reason.
x.org config says it should be enabled, this worked fine with
X 4.3
x.org doesn't even give a reason in the logs, which is a pain
the kernel supports it and X4.3 (and I assume 4.4 would) are
we stuck without dri with x.org?
Or at least there should be some kind of diagnosis that I can do to
help solve this?
nothing in Xorg.0.log just (II) RADEON(0): Direct rendering disabled
and the dri module has loaded fine, on both computers.
Used the standard creation of the config from gui on both.
no errors except (WW) Open APM failed (/dev/apm_bios) (No such device)
on my desktop (which is normal for X on this)
tried adding 	Option      "DRI" "true"
as in docs for x.org but must have that wrong as it doesn't recognise it.
What am I missing?

Cheers,

Malc
Comment 1 Malcolm Amir Hussain-Gambles 2004-05-31 07:35:00 EDT
I have radeon 9800 this is apparently not yet supported. nice!
Looking further into the reason the laptop one fails.
Comment 2 Mike A. Harris 2004-06-01 05:03:27 EDT
DRI does not support Radeon 9500/9600/9700/9800 or newer ATI hardware.
All of these cards and all variants are 2D only in X using the
supplied drivers.  Both X.org and XFree86 radeon drivers are the
same source code essentially.  This is not a limitation of either
X implementation, but rather is due to open source drivers just not
supporting DRI on newer ATI hardware.

Once the specifications for 3D support are released to developers
for this hardware, future X releases may include DRI support.

Closing as 'NOTABUG'
Comment 3 Malcolm Amir Hussain-Gambles 2004-06-01 07:38:19 EDT
OK, but what about the card in the laptop I was mentioning?
01:00.0 VGA compatible controller: S3 Inc. VT8375 [ProSavage8 KM266/KL266]

It doesn't look like that is supported either, but there is nothing to
say it is or isn't
Comment 4 Mike A. Harris 2004-06-01 10:15:22 EDT
The savage driver does not support DRI.  The easy way to tell wether
or not DRI is supported on any hardware, is to ensure the following
line is in your X config file:

    Load "dri"

That enables the DRI extension.  If the video driver you are using
supports DRI, and it supports the chip you are using, you will see
a "DRI Enabled" message in the X server log file.  If you see anywhere
in the log file "DRI Disabled", then the hardware is not supported
by DRI.

There is additional information about what video hardware is and
is not supported at the DRI website at:  http://dri.sf.net

The DRI project also runs several mailing lists which might be useful
if you're unsure about a particular brand/model of card and whether
it is supported by any particular XFree86 or X.Org X11 release.

Hope this helps.

Note You need to log in before you can comment on or make changes to this bug.