Bug 1247307 - It's not possible to apply the patch on windows due to path length limitation
It's not possible to apply the patch on windows due to path length limitation
Status: CLOSED ERRATA
Product: JBoss Operations Network
Classification: JBoss
Component: Launch Scripts (Show other bugs)
JON 3.3.3
Unspecified Unspecified
unspecified Severity urgent
: CR02
: JON 3.3.3
Assigned To: Simeon Pinder
Filip Brychta
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-27 14:24 EDT by Filip Brychta
Modified: 2015-08-07 03:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-07 03:43:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Filip Brychta 2015-07-27 14:24:41 EDT
Description of problem:
The patch is trying to copy files which are located deep in directory structure so the paths are too long and fails due to windows path length limitation.

Version-Release number of selected component (if applicable):
JON 3.3.3_CR01

How reproducible:
Always

Steps to Reproduce:
1. install jon 3.3.0.GA
2. stop all components
3. apply the patch

Actual results:
c:\>jon-server-3.3.0.GA-update-03\apply-updates.bat jon-server-3.3.0.GA
[Mon 07/27/2015 11:13:53.22] Starting Update

  Successfully detected server to update [c:\jon-server-3.3.0.GA]
  Proceeding with application of patch [03] to [c:\jon-server-3.3.0.GA]

  Successfully detected agent to update [c:\jon-server-3.3.0.GA\..\rhq-agent]
  Proceeding with application of patch [03] to [c:\jon-server-3.3.0.GA\..\rhq-ag
ent]
  Assessing permissions needed during update process....
  Successfully verified that JON Server is already shut down.

  Certain patch files can not be overwritten due to name changes. These
  files are being archived.
  Archived server files will be moved to [c:\jon-server-3.3.0.GA\.patched\3.3.0.
GA-update-03_07-27-15_11-13-53\.old].
  Archived agent  files will be moved to [c:\jon-server-3.3.0.GA\.patched\3.3.0.
GA-update-03_07-27-15_11-13-53\.old-agent];
  See c:\jon-server-3.3.0.GA\.patched\3.3.0.GA-update-03_07-27-15_11-13-53\updat
e.log for more archive details.

The system cannot find the batch label specified - exitearly



From update.log:
[Mon 07/27/2015 11:15:55.95] Archiving
    [c:\jon-server-3.3.0.GA\modules\org\rhq\server-startup\main\deployments\rhq.ear\rhq-portal.war\WEB-INF\classes\org\rhq\enterprise\gui\legacy\action\resource\common\monitor\alerts\config\condition\CallTimeDataConverterValidator.class] to:
    [c:\jon-server-3.3.0.GA\.patched\3.3.0.GA-update-03_07-27-15_11-13-53\.old\modules\org\rhq\server-startup\main\deployments\rhq.ear\rhq-portal.war\WEB-INF\classes\org\rhq\enterprise\gui\legacy\action\resource\common\monitor\alerts\config\condition\]
[Mon 07/27/2015 11:15:55.97] xcopy /y /c /h /r "c:\jon-server-3.3.0.GA\modules\org\rhq\server-startup\main\deployments\rhq.ear\rhq-portal.war\WEB-INF\classes\org\rhq\enterprise\gui\legacy\action\resource\common\monitor\alerts\config\condition\CallTimeDataConverterValidator.class" "c:\jon-server-3.3.0.GA\.patched\3.3.0.GA-update-03_07-27-15_11-13-53\.old\modules\org\rhq\server-startup\main\deployments\rhq.ear\rhq-portal.war\WEB-INF\classes\org\rhq\enterprise\gui\legacy\action\resource\common\monitor\alerts\config\condition\"
Insufficient memory
0 File(s) copied
[!DATE! !TIME!] del /f /q "!_SRC_FILE!"
Could Not Find c:\!_SRC_FILE!
[!DATE! !TIME!] del /f /q "!_SRC_FILE!"
Could Not Find c:\!_SRC_FILE!

Expected results:
No errors
Comment 4 Filip Brychta 2015-07-29 04:35:39 EDT
Verified that build from comment 2 contains changes only in following files:    apply-updates.bat
jon-server-3.3.0.GA-update-03.txt

that sequential update works (JON 3.3.0.GA -> CP2 -> CP3)
that direct update works (JON 3.3.0.GA -> CP3)

Previous works only if the $JON_HOME is located at root e.g. c:\
The issue is still visible when the $JON_HOME is located deeper in dir structure e.g. c:\jon-system\ - this case will be covered by bz 1247311

Note You need to log in before you can comment on or make changes to this bug.