Bug 1247315 - Fix limitation in iproute/ss regarding dual-stack sockets
Fix limitation in iproute/ss regarding dual-stack sockets
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: iproute (Show other bugs)
7.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Phil Sutter
Jaroslav Aster
:
: 1244313 (view as bug list)
Depends On: 1247309
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-27 14:36 EDT by Phil Sutter
Modified: 2015-11-19 09:42 EST (History)
2 users (show)

See Also:
Fixed In Version: iproute-3.10.0-48.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1247728 (view as bug list)
Environment:
Last Closed: 2015-11-19 09:42:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2117 normal SHIPPED_LIVE iproute bug fix and enhancement update 2015-11-19 06:35:06 EST

  None (edit)
Description Phil Sutter 2015-07-27 14:36:06 EDT
When listing listening sockets using 'ss -nlpe', there is no indication about whether an AF_INET6 socket is dual-stack capable, i.e. allows access from IPv4 as well. The following upstream patch solves this issue:

commit f32dc7467fee0b9e55c3fc6e2895d62e881dec55
Author: Phil Sutter <phil@nwl.cc>
Date:   Wed Jun 24 13:07:20 2015 +0200

    ss: print value of IPV6_V6ONLY socket option if set
    
    If available and set, print 'v6only:1' for AF_INET6 sockets upon request
    of extended information. For IPv6 sockets bound to in6addr_any, this is
    the only way to determine if they will also accept IPv4 requests or not.
    
    Signed-off-by: Phil Sutter <phil@nwl.cc>
Comment 1 Phil Sutter 2015-07-27 14:38:22 EDT
*** Bug 1244313 has been marked as a duplicate of this bug. ***
Comment 6 errata-xmlrpc 2015-11-19 09:42:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2117.html

Note You need to log in before you can comment on or make changes to this bug.