This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1247335 - silent ABI break in c5145b6816b1a771daa8c0282c34bd303a360f56
silent ABI break in c5145b6816b1a771daa8c0282c34bd303a360f56
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hawkey (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-27 15:07 EDT by Colin Walters
Modified: 2015-08-10 22:08 EDT (History)
9 users (show)

See Also:
Fixed In Version: dnf-1.0.2-3.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-10 22:08:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Walters 2015-07-27 15:07:41 EDT
https://github.com/rpm-software-management/hawkey/commit/c5145b6816b1a771daa8c0282c34bd303a360f56 is a silent ABI break - new values were added into the middle of an enumeration.

This broke libhif, which in turn broke rpm-ostree, which in turn broke Fedora updates-testing composes.

In the end, it's not a big deal, we'll just rebuild libhif.

However, this cost quite a bit of debugging time from multiple people.
Comment 1 Fedora Update System 2015-07-27 15:23:48 EDT
dnf-1.0.2-2.fc22, hawkey-0.5.9-2.fc22, libhif-0.2.0-6.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/libhif-0.2.0-6.fc22,dnf-1.0.2-2.fc22,hawkey-0.5.9-2.fc22
Comment 2 Radek Holy 2015-07-28 04:38:09 EDT
OMG, I cannot believe that we did it again...
Comment 3 Kalev Lember 2015-07-28 08:20:32 EDT
The enum ABI change seems to affect PackageKit as well, not just libhif. I wonder if it would make sense to fix the ABI break in hawkey instead of rebuilding all the consumers?

PackageKit links directly to hawkey as well as using it through libhif and uses the affected enum where the ABI changed.

Avoiding the ABI changes seems a bit safer since it allows using newer hawkey together with older consumers -- a broken dep or whatever could possibly result in a partial system upgrade where a consumer is kept back and only hawkey is updated.
Comment 4 Richard Hughes 2015-07-28 08:48:58 EDT
(In reply to Radek Holy from comment #2)
> OMG, I cannot believe that we did it again...

I thought I was supposed to be given the heads up on new librepo + hawkey releases? There was no "We're about to release..." or release announcement on rpm-ecosystem@lists.rpm.org and I had no idea about the new release until Kalev pointed me at this bug.
Comment 6 Honza Silhan 2015-07-30 08:57:02 EDT
Sorry for that break and thanks for fixing it.

(In reply to Richard Hughes from comment #4)
> I thought I was supposed to be given the heads up on new librepo + hawkey
> releases? There was no "We're about to release..." or release announcement
> on rpm-ecosystem@lists.rpm.or yum devel.

Next time we will announce it. We do the new release of hawkey usually with the new release of DNF (announced on fedora-devel and yum-devel). Or you can add yourself to watchers for hawkey [1].

[1] https://admin.fedoraproject.org/pkgdb/package/hawkey/
Comment 7 Fedora Update System 2015-07-31 22:28:51 EDT
Package dnf-1.0.2-3.fc22, hawkey-0.5.9-3.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-1.0.2-3.fc22 hawkey-0.5.9-3.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-12577/dnf-1.0.2-3.fc22,hawkey-0.5.9-3.fc22
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2015-08-10 22:08:54 EDT
dnf-1.0.2-3.fc22, hawkey-0.5.9-3.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.