Bug 1247368 - [abrt] libreoffice-core: getObjectOffset(): soffice.bin killed by SIGSEGV
[abrt] libreoffice-core: getObjectOffset(): soffice.bin killed by SIGSEGV
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
22
x86_64 Unspecified
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:14d5fd6de403dd6dc5e11df3769...
:
Depends On: 1242183
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-27 16:26 EDT by Luya Tshimbalanga
Modified: 2017-02-20 07:26 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 21:57:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (131.71 KB, text/plain)
2015-07-27 16:26 EDT, Luya Tshimbalanga
no flags Details
File: cgroup (190 bytes, text/plain)
2015-07-27 16:26 EDT, Luya Tshimbalanga
no flags Details
File: core_backtrace (43.05 KB, text/plain)
2015-07-27 16:26 EDT, Luya Tshimbalanga
no flags Details
File: dso_list (25.32 KB, text/plain)
2015-07-27 16:26 EDT, Luya Tshimbalanga
no flags Details
File: environ (3.10 KB, text/plain)
2015-07-27 16:26 EDT, Luya Tshimbalanga
no flags Details
File: limits (1.29 KB, text/plain)
2015-07-27 16:26 EDT, Luya Tshimbalanga
no flags Details
File: maps (132.62 KB, text/plain)
2015-07-27 16:26 EDT, Luya Tshimbalanga
no flags Details
File: mountinfo (3.72 KB, text/plain)
2015-07-27 16:26 EDT, Luya Tshimbalanga
no flags Details
File: namespaces (85 bytes, text/plain)
2015-07-27 16:26 EDT, Luya Tshimbalanga
no flags Details
File: open_fds (3.51 KB, text/plain)
2015-07-27 16:26 EDT, Luya Tshimbalanga
no flags Details
File: proc_pid_status (964 bytes, text/plain)
2015-07-27 16:26 EDT, Luya Tshimbalanga
no flags Details
File: var_log_messages (572 bytes, text/plain)
2015-07-27 16:26 EDT, Luya Tshimbalanga
no flags Details

  None (edit)
Description Luya Tshimbalanga 2015-07-27 16:26:38 EDT
Description of problem:
Open a xls file with LibreOffice Calc

Version-Release number of selected component:
libreoffice-core-4.4.4.3-6.fc22

Additional info:
reporter:       libreport-2.6.1
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --calc file:///run/media/luya/Small%20Business%20F/Small%20Business%20Forms/forms/word/business%20start%20up/PersonalNetWorth.xls --splash-pipe=5
crash_function: getObjectOffset
executable:     /usr/lib64/libreoffice/program/soffice.bin
global_pid:     12951
kernel:         4.0.8-300.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 getObjectOffset at /usr/src/debug/llvm-3.5.0.src/include/llvm/CodeGen/MachineFrameInfo.h:413
 #1 llvm::SIRegisterInfo::eliminateFrameIndex at SIRegisterInfo.cpp:54
 #2 llvm::RegScavenger::scavengeRegister at RegisterScavenging.cpp:422
 #3 llvm::SIRegisterInfo::eliminateFrameIndex at SIRegisterInfo.cpp:58
 #4 llvm::RegScavenger::scavengeRegister at RegisterScavenging.cpp:422
 #5 llvm::SIRegisterInfo::eliminateFrameIndex at SIRegisterInfo.cpp:58
 #6 llvm::RegScavenger::scavengeRegister at RegisterScavenging.cpp:422
 #7 llvm::SIRegisterInfo::eliminateFrameIndex at SIRegisterInfo.cpp:58
 #8 llvm::RegScavenger::scavengeRegister at RegisterScavenging.cpp:422
 #9 llvm::SIRegisterInfo::eliminateFrameIndex at SIRegisterInfo.cpp:58
Comment 1 Luya Tshimbalanga 2015-07-27 16:26:42 EDT
Created attachment 1056743 [details]
File: backtrace
Comment 2 Luya Tshimbalanga 2015-07-27 16:26:43 EDT
Created attachment 1056744 [details]
File: cgroup
Comment 3 Luya Tshimbalanga 2015-07-27 16:26:44 EDT
Created attachment 1056745 [details]
File: core_backtrace
Comment 4 Luya Tshimbalanga 2015-07-27 16:26:45 EDT
Created attachment 1056746 [details]
File: dso_list
Comment 5 Luya Tshimbalanga 2015-07-27 16:26:46 EDT
Created attachment 1056747 [details]
File: environ
Comment 6 Luya Tshimbalanga 2015-07-27 16:26:47 EDT
Created attachment 1056748 [details]
File: limits
Comment 7 Luya Tshimbalanga 2015-07-27 16:26:49 EDT
Created attachment 1056749 [details]
File: maps
Comment 8 Luya Tshimbalanga 2015-07-27 16:26:50 EDT
Created attachment 1056750 [details]
File: mountinfo
Comment 9 Luya Tshimbalanga 2015-07-27 16:26:51 EDT
Created attachment 1056751 [details]
File: namespaces
Comment 10 Luya Tshimbalanga 2015-07-27 16:26:52 EDT
Created attachment 1056752 [details]
File: open_fds
Comment 11 Luya Tshimbalanga 2015-07-27 16:26:52 EDT
Created attachment 1056753 [details]
File: proc_pid_status
Comment 12 Luya Tshimbalanga 2015-07-27 16:26:53 EDT
Created attachment 1056754 [details]
File: var_log_messages
Comment 13 Luya Tshimbalanga 2015-08-11 23:35:21 EDT
Updated Calc to 4.4.5.2. The bug is still occur with xls file. Here is the hardware information it runs on:

Processor: AMD A10-7400P Radeon R6 10 Compute Cores 4C+6G @ 2.50GHz (4 Cores), Motherboard: ASUS X550ZE v1.0, 
Chipset: AMD Family 15h, 
Memory: 7168MB, 
Disk: 1000GB Seagate ST1000LM024 HN-M, 
Graphics: ASUS AMD Radeon R6 1024MB,
Comment 14 Luya Tshimbalanga 2015-08-12 00:36:03 EDT
It turned out the bug is caused by the use of enabled OpenGL option. (View rhbz #1242183). Disabling the use of OpenGL solves the problem on LibreOffice 4.4.X. It seems to be a driver problem. Caolan, can you check if you can reproduce the bug with OpenGL option from Tools -> Options -> LibreOffice -> View
Comment 15 Luya Tshimbalanga 2015-08-13 17:51:47 EDT
I added the related bug due to OpenGL issue.
Comment 16 Luya Tshimbalanga 2015-11-04 21:57:48 EST
Closing this bug now the updated fixed the issue.

Note You need to log in before you can comment on or make changes to this bug.