This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 124737 - Installer complains about two partitions, part of a raid-1 volume, having the same disk label
Installer complains about two partitions, part of a raid-1 volume, having the...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
FC3
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-28 18:56 EDT by Per Losenborg
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-18 11:12:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Dump of the Anaconda log (213.92 KB, text/plain)
2005-06-15 21:46 EDT, Nathan G. Grennan
no flags Details

  None (edit)
Description Per Losenborg 2004-05-28 18:56:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
When running an upgrade (graphical mode) from a FC1 system the
installer complains about two partitions having the same disk label
and refuses to continue.

The two partitions DO have the same disk label since they are part of
a RAID-1 volume but the label is not used in /etc/fstab (or anywhere
else I know about) on the original FC1 installation.

Work around: Boot the old system and run '/sbin/tune2fs -L ""
/dev/mdX' where X is the raid-1 volume containing the disk label.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create a RAID-1 volume with an ext2/3 file system
2.Label the raid volume
3.Try to run an upgrade to FC2.
    

Actual Results:  Told that the installer could not continue with two
partitions having the same label. Asked to reboot the system (and
abort the upgrade).

Expected Results:  Be able to run the upgrade without having to erase
the disk label.

Additional info:
Comment 1 Paul Nasrat 2004-06-02 11:12:33 EDT
I'm investigating this currently - I have setup a Fedora Core 1
install using RAID-1 kickstarted with the following partitioning setup:

clearpart --linux
part /boot --fstype ext3 --size=150
part raid.15 --size=4096
part raid.13 --size=4096
part / --fstype ext3 --size=2048
part swap --size=1024
raid /usr --fstype ext3 --level=RAID1 raid.15 raid.13

I boot into FC1 and use e2label /dev/md0 /usr to label the RAID
device.  I then manually perform a Fedora Core 2 upgrade - that all
seems fine here - no error messages from anaconda about disk labels.

I've also tried with / on RAID-1 too and I sill don't see an error.
Could you expand on your steps to reproduce and also tell me at what
stage you see the error.
Comment 2 Per Losenborg 2004-06-03 07:02:39 EDT
Since my original system is upgraded I created a new FC1 installation
in a VMWare virtual machine with two "physical" disks, sda and sdb.

FC1 installation (graphical mode)
Custom installation, minimal

/etc/fstab:
/dev/sda1	/	  ext3	defaults 1 1
/dev/sdb1	/usr	  ext3	defaults 1 2
...
/dev/sda2	swap	  swap	defaults 0 0
/dev/sdb2	swap	  swap	defaults 0 0
/dev/md0	/mnt/foo  ext3	defaults 1 2

/etc/raidtab:
raiddev		/dev/md0
raid-level	1
nr-raid-disks	2
chunk-size	64
persistent-superblocks 1
nr-spare-disks  0
  device	/dev/sda5
  raid-disk	0
  device	/dev/sdb5
  raid-disk	1
	
/sbin/mkraid    /dev/md0
/sbin/mkfs.ext3 /dev/md0
/sbin/e2label   /dev/md0 "MISC"

FC2 upgrade (graphical mode)
...
Language Selection: English (English)
Keyboard Configuration: Swedish
Monitor Configuration: Unprobed Monitor
Select "Upgrade an existing installation" and klick "Next". 

A notice pops up with the message:

                   Duplicate Labels
  Multiple devices on your system are labelled MISC. Labels
  across devices must be unique for your system to function
  propery.

  Please fix this problem and restart the installation process.
                                               [Reboot]


Boot into FC1 and run
umount /mnt/foo 
/sbin/tune2fs /dev/md0 -L ""
/sbin/reboot 

FC2 upgrade gives an error message at the same step as above:

                          Error
  Error mounting device md0 as /mnt/foo: Invalid argument
  This most likely means this partition has not been formatted.
  Press OK to reboot your system.
                                                [OK]

Boot FC1 to verify that /mnt/foo is mounted and ready. Place a #
before /dev/md0 in /etc/fstab to run the FC2 upgrade process without
any problem.

Boot the upgraded FC2, uncomment /dev/md0 in fstab and reboot.
/mnt/foo is mounted and ready. Add a disk label with /sbin/e2label
/dev/md0 "MISC" and reboot to verify that /mnt/foo is mounted without
problem.
Comment 3 Paul Nasrat 2004-06-03 09:45:21 EDT
Thanks for the detail - I'm investigating further.
Comment 4 Jeremy Katz 2005-04-14 17:07:34 EDT
Does this still happen with newer releases?
Comment 5 Per Losenborg 2005-05-18 09:26:45 EDT
I just did an upgrade from FC3 to FC4 test 3 as described in comment #2 without
any problems.
Comment 6 Matthew Miller 2005-05-18 11:12:33 EDT
As per comment #5, resolving this as closed:rawhide.
Comment 7 Nathan G. Grennan 2005-06-15 21:45:46 EDT
I just ran into this problem with the upgrade from FC3 to FC4. I am using three
raid1 arrays. e2label suggests that the partitions and arrays don't have labels,
since it comes back with a blank line for each. I even tried echo \"`e2label
device`\" for each device and just got "" each time.

The log from anaconda that I had it save to a floppy suggests that there are
extended ascii characters for labels of two of the devices.

I will attach the error log.

Comment 8 Nathan G. Grennan 2005-06-15 21:46:47 EDT
Created attachment 115516 [details]
Dump of the Anaconda log

Note You need to log in before you can comment on or make changes to this bug.