Bug 1247377 - Snapshot disks become illegal while deleting snapshot [NEEDINFO]
Snapshot disks become illegal while deleting snapshot
Status: CLOSED DUPLICATE of bug 1247379
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.5.1
x86_64 Linux
unspecified Severity high
: ---
: 3.5.5
Assigned To: Greg Padgett
Aharon Canan
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-27 16:40 EDT by dev-unix-virtualization
Modified: 2016-02-10 12:29 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-28 03:50:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amureini: needinfo? (dev-unix-virtualization)


Attachments (Terms of Use)
screenshot of illegal snapshot on RHEV-M (24.61 KB, image/jpeg)
2015-07-27 16:40 EDT, dev-unix-virtualization
no flags Details

  None (edit)
Description dev-unix-virtualization 2015-07-27 16:40:02 EDT
Created attachment 1056757 [details]
screenshot of illegal snapshot on RHEV-M

Description of problem:
While deleting snapshot, the snapshot disk becomes illegal.After that we are not able to delete the snapshot.

Here is the engine log at that point of time. Also attached the screenshot of the illegal status of snapshot disk.


5972 2015-07-17 10:14:50,093 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.MergeVDSCommand] (pool-6-thread-7) [bf8cdd] START, MergeVDSCommand(HostName = gondor, MergeVDSCommandParameters{HostId = 9d8afedd-92ba-4672-bce9-923bb2c9e900, vmId=8f8e3218-effe-457c-80be-3c759b65bc9d, storagePoolId=00000002-0002-0002-0002-00000000001c, storageDomainId=8b6847b2-0c3f-47d2-af5a-a81842cf5eb0, imageGroupId=ecacc8fb-7b06-4125-9e70-60aa4cb85e4c, imageId=1eb5f902-abce-49cc-b626-4dce7aa5c7a5, baseImageId=707900f5-48e9-48d4-b9b6-45e0138a9790, topImageId=1eb5f902-abce-49cc-b626-4dce7aa5c7a5, bandwidth=0}), log id: 501b7363
5973 2015-07-17 10:14:50,098 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.MergeVDSCommand] (pool-6-thread-7) [bf8cdd] Failed in MergeVDS method
5974 2015-07-17 10:14:50,098 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.MergeVDSCommand] (pool-6-thread-7) [bf8cdd] Command org.ovirt.engine.core.vdsbroker.vdsbroker.MergeVDSCommand return value
5975  StatusOnlyReturnForXmlRpc [mStatus=StatusForXmlRpc [mCode=13, mMessage=Drive image file could not be found]]
5976 2015-07-17 10:14:50,098 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.MergeVDSCommand] (pool-6-thread-7) [bf8cdd] HostName = gondor
5977 2015-07-17 10:14:50,098 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.MergeVDSCommand] (pool-6-thread-7) [bf8cdd] Command MergeVDSCommand(HostName = gondor, MergeVDSCommandParameters{HostId = 9d8afedd-92ba-4672-bce9-923bb2c9e900, vmId=8f8e3218-effe-457c-80be-3c759b65bc9d, storagePoolId=00000002-0002-0002-0002-00000000001c, storageDomainId=8b6847b2-0c3f-47d2-af5a-a81842cf5eb0, imageGroupId=ecacc8fb-7b06-4125-9e70-60aa4cb85e4c, imageId=1eb5f902-abce-49cc-b626-4dce7aa5c7a5, baseImageId=707900f5-48e9-48d4-b9b6-45e0138a9790, topImageId=1eb5f902-abce-49cc-b626-4dce7aa5c7a5, bandwidth=0}) execution failed. Exception: VDSErrorException: VDSGenericException: VDS ErrorException: Failed to MergeVDS, error = Drive image file could not be found, code = 13
5978 2015-07-17 10:14:50,098 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.MergeVDSCommand] (pool-6-thread-7) [bf8cdd] FINISH, MergeVDSCommand, log id: 501b7363
5979 2015-07-17 10:14:50,099 ERROR [org.ovirt.engine.core.bll.MergeCommand] (pool-6-thread-7) [bf8cdd] Command org.ovirt.engine.core.bll.MergeCommand throw Vdc Bll exception. With error message VdcBLLException: org.ovirt.engine.core.vdsbroker.vdsbroker.VDSErrorException: VDSGenericException: VDSErrorException: Failed to MergeVDS, error = Drive image file could not be found, code = 13 (Failed with error imageErr and code 13)
5980 2015-07-17 10:14:50,110 ERROR [org.ovirt.engine.core.bll.MergeCommand] (pool-6-thread-7) [bf8cdd] Transaction rolled-back for command: org.ovirt.engine.core.bll.Merge Command.
5981 2015-07-17 10:15:00,090 ERROR [org.ovirt.engine.core.bll.RemoveSnapshotSingleDiskLiveCommand] (DefaultQuartzScheduler_Worker-26) [3e58976f] Failed child command status for step MERGE
5982 2015-07-17 10:15:00,114 INFO  [org.ovirt.engine.core.bll.RemoveSnapshotCommandCallback] (DefaultQuartzScheduler_Worker-26) [59e4bf06] All Live Merge child commands have completed, status FAILED
5983 2015-07-17 10:15:10,129 ERROR [org.ovirt.engine.core.bll.RemoveSnapshotSingleDiskLiveCommand] (DefaultQuartzScheduler_Worker-44) [3e58976f] Merging of snapshot e2f1b725-c425-4eda-9605-78ba32ae335e images 707900f5-48e9-48d4-b9b6-45e0138a9790..1eb5f902-abce-49cc-b626-4dce7aa5c7a5 failed. Images have been marked illegal and can no longer be previewed or reverted to. Please retry Live Merge on the snapshot to complete the operation.
5984 2015-07-17 10:15:10,141 ERROR [org.ovirt.engine.core.bll.RemoveSnapshotCommand] (DefaultQuartzScheduler_Worker-44) [59e4bf06] Ending command with failure: org.ovirt.engine.core.bll.RemoveSnapshotCommand
5985 2015-07-17 10:15:10,170 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (DefaultQuartzScheduler_Worker-44) [59e4bf06] Correlation ID: 59e4bf06, Call Stack: null, Custom Event ID: -1, Message: Failed to delete snapshot '_GX_BACKUP_wwdeadvm1_43150_28803_adad2700' for VM 'wwdeadvm1'.
5986 2015-07-17 10:15:37,432 INFO  [org.ovirt.engine.core.bll.aaa.LoginUserCommand] (ajp-/127.0.0.1:8702-2) Running command: LoginUserCommand internal: false.
5987 2015-07-17 10:15:37,447 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ajp-/127.0.0.1:8702-2) Correlation ID: null, Call Stack: null, Custom Event ID: -1, Message: User admin@internal logged in.
5988 2015-07-17 10:15:37,504 INFO  [org.ovirt.engine.core.bll.aaa.LogoutBySessionCommand] (ajp-/127.0.0.1:8702-2) [43892f81] Running command: LogoutBySessionCommand internal: false.
Comment 1 Allon Mureinik 2015-07-28 03:50:06 EDT
This bug seems like an accidental double post of bug 1247379.

Commvault stakeholders - if this is not the case, please reopen this BZ and explain the differences from bug 1247379.
Thanks!

*** This bug has been marked as a duplicate of bug 1247379 ***

Note You need to log in before you can comment on or make changes to this bug.