Bug 1247387 - Enabling errata email notification without configuring email server breaks syncs, publishing and promotions
Enabling errata email notification without configuring email server breaks sy...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Other (Show other bugs)
Unspecified
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Mike McCune
Tazim Kolhar
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-27 17:03 EDT by Og Maciel
Modified: 2017-02-23 14:49 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-12 12:05:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Og Maciel 2015-07-27 17:03:08 EDT
Description of problem:

Using the web UI, I started editing my user account (admin) and noticing that I had the Email Notification checkbox enabled by default, I proceeded to (still using the web ui) enable several types of email notifications, including errata notification.

Later on, I happened to restart katello-service and my updates to my account were 'picked up'. I then tried to publish a new content view, which failed with an error stating:

  "SocketError: getaddrinfo: Name or service not known"

Turns out that, if you start looking into the dynflow task itself, you can see that the real error occurred while trying to send out an email about the errata that this publishing could have made available.

I feel that this is a potential blocker for the user, because, by simply using the web ui and NOT editing /etc/foreman/email.yaml (see http://www.katello.org/docs/2.3/user_guide/email_notifications/index.html) I can render my Satellite completely useless. Since Errata emails are generated every time one syncs a repo or publishes/promotes a content view, the task would error out and the action would never end.

I feel that we should not allow such a thing to happen solely because I changed a configuration using the web ui. Perhaps a warning about emails not being sent should be displayed but the task itself should not fail.



Version-Release number of selected component (if applicable):

* Satellite 6.1.1 SNAP 14

How reproducible:


Steps to Reproduce:
1. Use the web ui and subscribe the admin user to all available notification emails
2. Create a custom product (or use an existing one) and synchronize it; better yet, use an existing content view and try to publish it
3.

Actual results:

The task fails with an error

Expected results:


Additional info:
Comment 2 Mike McCune 2015-07-27 19:17:51 EDT
Created redmine issue http://projects.theforeman.org/issues/11228 from this bug
Comment 3 Mike McCune 2015-07-28 00:50:29 EDT
PR:

https://github.com/Katello/katello/pull/5378
Comment 5 Tazim Kolhar 2015-07-30 11:02:05 EDT
VERIFIED
# rpm -qa | grep foreman
foreman-1.7.2.33-1.el7sat.noarch
ruby193-rubygem-foreman-redhat_access-0.2.1-1.el7sat.noarch
foreman-vmware-1.7.2.33-1.el7sat.noarch
rubygem-hammer_cli_foreman-0.1.4.14-1.el7sat.noarch
ruby193-rubygem-foreman_gutterball-0.0.1.9-1.el7sat.noarch
foreman-postgresql-1.7.2.33-1.el7sat.noarch
foreman-debug-1.7.2.33-1.el7sat.noarch
foreman-gce-1.7.2.33-1.el7sat.noarch
ruby193-rubygem-foreman_hooks-0.3.7-2.el7sat.noarch
rubygem-hammer_cli_foreman_bootdisk-0.1.2.7-1.el7sat.noarch
rubygem-hammer_cli_foreman_docker-0.0.3.9-1.el7sat.noarch
ruby193-rubygem-foreman_docker-1.2.0.18-1.el7sat.noarch
ruby193-rubygem-foreman_discovery-2.0.0.19-1.el7sat.noarch
rubygem-hammer_cli_foreman_discovery-0.0.1.10-1.el7sat.noarch
foreman-proxy-1.7.2.5-1.el7sat.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-ovirt-1.7.2.33-1.el7sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3.5-1.el7sat.noarch
foreman-selinux-1.7.2.13-1.el7sat.noarch
ruby193-rubygem-foreman_bootdisk-4.0.2.13-1.el7sat.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-1.noarch
foreman-compute-1.7.2.33-1.el7sat.noarch
ruby193-rubygem-foreman-tasks-0.6.15.4-1.el7sat.noarch
foreman-libvirt-1.7.2.33-1.el7sat.noarch

steps:
1. Use the web ui and subscribe the admin user to all available notification emails
2. Create a custom product (or use an existing one) and synchronize it; better yet, use an existing content view and try to publish it

the task is successful
Comment 6 Bryan Kearney 2015-08-12 12:05:11 EDT
This bug was fixed in Satellite 6.1.1 which was delivered on 12 August, 2015.

Note You need to log in before you can comment on or make changes to this bug.