Bug 1247434 - virt-install gives incorrect warning about console=ttyS0
virt-install gives incorrect warning about console=ttyS0
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager (Show other bugs)
7.2
ppc64le Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Pavel Hrdina
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-27 21:42 EDT by David Gibson
Modified: 2016-11-03 21:58 EDT (History)
5 users (show)

See Also:
Fixed In Version: virt-manager-1.3.2-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 21:58:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Gibson 2015-07-27 21:42:35 EDT
Description of problem:

When installing a guest on Power using virt-install with a "serial" console (actually the paravirtualized hypervisor console), virt-install gives this warning:

    WARNING  No 'console' seen in --extra-args, a 'console=ttyS0'
    kernel argument is likely required to see text install output
    from the guest.

This warning is incorrect on two counts: 1) the console= argument is not actually necessary because the Power kernel/userspace automatically use the hypervisor console as well a a graphical console if present,  2) to explicitly select the hypervisor console, the correct argument is console=hvc0, not console=ttyS0 (since it's not actually a serial console).

Basically, for Power systems, having only the hypervisor console, but not VGA console is the normal, rather than the exceptional case.

Version-Release number of selected component (if applicable):

virt-install-1.2.1-3.el7.noarch
virt-manager-common-1.2.1-3.el7.noarch
libvirt-daemon-kvm-1.2.17-2.el7.ppc64le

How reproducible:

100%

Steps to Reproduce:

1. virt-install \
      --name test \
      --location http://download.lab.bos.redhat.com/.../os/ \
      --ram=2048 \
      --vcpus=1 \
      --accelerate \
      --os-variant=rhel7.0 \
      --graphics none \
      --network network=default,model=virtio \
      --disk size=10,bus=scsi

Actual results:

Installer prints the warning described above before continuing successfully with installation.

Expected results:

Installation runs without warning.
Comment 2 Pavel Hrdina 2016-02-29 10:41:51 EST
Upstream commit:

commit 0e26031096b332d2424f701fdb8ec9205a53bb0e
Author: Pavel Hrdina <phrdina@redhat.com>
Date:   Mon Nov 9 15:15:43 2015 +0100

    virt-install: don't report missing console in extra-args for ppc64
Comment 3 Mike McCune 2016-03-28 19:17:33 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 5 xiaodwan 2016-07-19 02:42:28 EDT
I can reproduce it with virt-manager-1.2.1-8.el7.noarch.

Steps:
# virt-install --name testvm --memory 1024 --disk /var/lib/libvirt/images/testvm.img,size=5 -l http://download.eng.pek2.redhat.com//pub/rhel/released/RHEL-7/7.2/Server/ppc64le/os/ --graphics none
WARNING  No 'console' seen in --extra-args, a 'console=ttyS0' kernel argument is likely required to see text install output from the guest.

Then verified it with latest virt-manager-1.4.0-1.el7.noarch, No above warning any more.

So move this bug from ON_QA to VERIFIED.
Comment 7 errata-xmlrpc 2016-11-03 21:58:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2269.html

Note You need to log in before you can comment on or make changes to this bug.