Bug 124744 - autofs init script ignores file overide for LDAP information
autofs init script ignores file overide for LDAP information
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-28 21:41 EDT by Omar El-Domeiri
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-21 11:21:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Omar El-Domeiri 2004-05-28 21:41:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Autofs init script ignores information in /etc/auto.master when a
mountpoint is duplicated in LDAP and in the file.  Previously LDAP
automount information could be used network wide and /etc/auto.master
could be used to override LDAP autofs information on a host by host basis.

I have automount information stored in LDAP for every host on the
network to use.  But on a given host we don't want it to automount
its own exports.  A solution using /etc/auto.master worked on fedora
core 1, but no longer works in fedora core 2.  I have narrowed the
problem down the init script for autofs. 


Version-Release number of selected component (if applicable):
autofs-4.1.2-2 (also broken in autofs-4.1.2-6)

How reproducible:
Always

Steps to Reproduce:
Here is the exact setup I have from the prespective of a host named
snowcrash:

/etc/nsswitch.conf contains:
    automount:  files ldap

There exists a directory /v where all the automount mountpoints are
mounted.  
    bash-2.05b$ ls -la /v
    drwxr-xr-x   2 root root    0 May 28 19:56 quicksilver
    lrwxrwxrwx   1 root root   12 May 28 16:41 snowcrash -> /d0/exports/

On quicksilver, snowcrash would be a directory and quicksilver
would be a symlink to /d0/exports

There exist LDAP automount information for quicksilver and snowcrash

    # auto.snowcrash, basedn
    dn: ou=auto.snowcrash,o=basedn
    objectClass: automountMap
    ou: auto.snowcrash

    # /v/snowcrash, auto.master, basedn
    dn: cn=/v/snowcrash,ou=auto.master,o=basedn
    objectClass: automount
    cn: /v/snowcrash
    automountInformation: ldap:localhost:ou=auto.snowcrash,o=basedn
--timeout 60

    # home, auto.snowcrash, basedn
    dn: cn=home,ou=auto.snowcrash,o=basedn
    objectClass: automount
    automountInformation: snowcrash:/d0/exports/home
    cn: home

Similar entries for quicksilver's mountpoints.

Then /etc/auto.master on snowcrash contains the following one line:
    /v/snowcrash -null

Similarly on quicksilver /etc/auto.master contains
    /v/quicksilver -null

Previously in fedora core 1 this line in each host's /etc/auto.master
would instruct autofs to ignore the ldap automount information for
that hosts exports.


Actual Results:  
With fedora core 2, autofs acts as if /etc/auto.master was 
empty!  This causes issues when /d0/exports attempts to mount on top
of itself, hiding all the information in /d0/exports, and rendering
/v/snowcrash useless.

Expected Results:  auto.master should override the /v/snowcrash ldap
automount information,
causing autofs to never attempt to automount /v/snowcrash.

Additional info:

My current solution is to overwrite /etc/init.d/autofs with the 
old fedora core 1 version of that init script.  So the problem is
definately with the fedora core 2 /etc/init.d/autofs init script.
Comment 1 Jeff Moyer 2004-06-02 14:32:51 EDT
Nothing is jumping out at me, here.  Could you please give me the log
output from a service autofs start, and afterwards, the output from a
service autofs status?  It would also be helpful to see your
/etc/auto.master file.

Note that the Linux automounter does not support the -null map.
Comment 2 Jeff Moyer 2005-04-11 16:18:33 EDT
I'm still waiting for more information on this one.
Comment 3 Jeff Moyer 2005-10-21 11:21:07 EDT
-null maps are not supported in autofs version 4.  This is something that is
being considered for the v5 work.

If you need this support in the current automounter, please file this bug
upstream: autofs@linux.kernel.org.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.