Bug 124749 - Can hear 'events', cannot hear CD
Can hear 'events', cannot hear CD
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: sndconfig (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-29 03:16 EDT by Bob Gustafson
Modified: 2014-03-16 22:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-11 12:59:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of amixer without any arguments (6.42 KB, text/plain)
2004-06-01 21:06 EDT, Bob Gustafson
no flags Details

  None (edit)
Description Bob Gustafson 2004-05-29 03:16:23 EDT
Description of problem:

  I cannot hear anything from the CD player. I do hear 'events'
though, so it seems as though the wiring to the external speakers,
etc. is working OK.

Version-Release number of selected component (if applicable):

  This is soon after doing a yum update \*  (excluding gimp and
subversion ...)

How reproducible:

  This problem has been there for a long time (I haven't ever heard
anything from this CD player).

Steps to Reproduce:
1. Boot
2. log in as user1, startx (I am booting into level 3)
3. Open CD Player in Gnome
4. Stick in CD
5. I can see track labels and the play time ticking away
6. I have played with all volume controls
7. Cannot hear sound from CD
  
Actual results:

  No sound from CD

Expected results:

  I should be able to play a CD

Additional info:

This is the log soon after boot and log in as user1 and startx

[root@hoho2 user1]# tail /var/log/messages
May 29 01:26:33 hoho2 kernel: intel8x0_measure_ac97_clock: measured
49822 usecs
May 29 01:26:33 hoho2 kernel: intel8x0: clocking to 48000
May 29 01:26:34 hoho2 bonobo-activation-server (user1-3027): iid
OAFIID:BrokenNoType:20000808 has a NULL type
May 29 01:26:34 hoho2 bonobo-activation-server (user1-3027): invalid
character '#' in iid 'OAFIID:This#!!%$iid%^$%_|~!OAFIID_ContainsBadChars'
May 29 01:26:36 hoho2 modprobe: FATAL: Error running install command
for sound_slot_1
May 29 01:26:47 hoho2 modprobe: FATAL: Error running install command
for sound_slot_1
May 29 01:27:07 hoho2 system-config-soundcard(pam_unix)[3145]:
authentication failure; logname= uid=500 euid=0 tty= ruser=user1
rhost=  user=user1
May 29 01:27:26 hoho2 system-config-soundcard(pam_unix)[3145]: auth
could not identify password for [user1]
May 29 01:27:28 hoho2 system-config-soundcard(pam_unix)[3145]: 1 more
authentication failure; logname= uid=500 euid=0 tty= ruser=user1
rhost=  user=user1
May 29 01:27:40 hoho2 su(pam_unix)[3167]: session opened for user root
by user1(uid=500)
[root@hoho2 user1]#
                                                                     
          
[root@hoho2 user1]# /sbin/lsmod | more
Module                  Size  Used by
snd_mixer_oss          17792  2
snd_intel8x0           31276  3
snd_ac97_codec         59140  1 snd_intel8x0
snd_pcm                76804  1 snd_intel8x0
snd_timer              22532  1 snd_pcm
snd_page_alloc         12040  2 snd_intel8x0,snd_pcm
gameport                7424  1 snd_intel8x0
snd_mpu401_uart         9088  1 snd_intel8x0
snd_rawmidi            21924  1 snd_mpu401_uart
snd_seq_device         10120  1 snd_rawmidi
snd                    45028  10
snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore              10336  3 snd
radeon                111956  2
ipv6                  214496  22
parport_pc             23616  1
lp                     12300  0
parport                34632  2 parport_pc,lp
autofs4                18052  0
sunrpc                119012  1
e1000                  73356  0
ipt_REJECT              8704  1
ipt_state               5504  1
ip_conntrack           30348  1 ipt_state
iptable_filter          6016  1
ip_tables              18048  3 ipt_REJECT,ipt_state,iptable_filter
floppy                 52336  0
sg                     32288  0
microcode              10400  0
dm_mod                 37536  0
uhci_hcd               28952  0
ehci_hcd               26628  0
button                  8600  0
battery                10892  0
asus_acpi              12952  0
ac                      7308  0
ext3                  108776  2
jbd                    50328  1 ext3
aic79xx               182812  4
sd_mod                 20352  6
scsi_mod               97608  3 sg,aic79xx,sd_mod
[root@hoho2 user1]#
Comment 1 Bill Nottingham 2004-06-01 00:54:36 EDT
What's the volume like for the CD in the mixer?
Comment 2 Bob Gustafson 2004-06-01 03:31:47 EDT
mixer? what mixer?

When I go into Preferences -> Volume Control

I see two tabs - 
Realtek ALX650 rev2 [Audio Mixer (OSS)] and
Intel 82801DB-iCH4 [Alsa Mixer]

All the volume control sliders that say CD are at the top, the Master
Control is at the top and the volume on the CD player applet is also
at the top. (hmm, those events are loud).

But no CD sounds

I have an onboard Intel PCM chip for sound - no sound blaster card or
other sound card.

Comment 3 Bill Nottingham 2004-06-01 12:17:58 EDT
Is there a cable from the CD to the motherboard for audio?

Did this work in previous releases?
Comment 4 Bob Gustafson 2004-06-01 14:09:46 EDT
An audio cable came in the box, but I think it is for the TV card - to
plug sound from TV card to Line-in. (Don't ask, haven't pulled TV
cable up to where the computer box is located..) TV application seems
to work though. Rabbit ears pulls in some fuxxy channels. But not
worth plugging in audio cable.

Haven't explored whether there is a cable connection (needed?) from CD
to motherboard. The CD is a Toshiba with DVD read capability and CD
burn ability. The motherboard is a Supermicro.

(I would give you model numbers, but I am temporarily locked out of
root (experimenting with SELinux..) - need to power cycle.

This is a relatively new machine. It was originally fitted out with
RH9. Playing CD records never did work (but I'm not much of a music
freak, so I did not push it).  I was upgrading various pieces of RH9
with Alsa in an attempt to get sound. Unsucessful.

Not a very good data point.

However, reading data CDs worked fine and burning CDs also worked fine.

This current (updated-devel) version of Fedora2 works for reading data
CDs, but I haven't figured out how to burn CDs from iso datafiles
(e.g., FC2 disks), so I reboot in RH9 and use gcombust.
Comment 5 Bill Nottingham 2004-06-01 14:33:03 EDT
Does playing CDs with something like 'grip' work?
Comment 6 Bob Gustafson 2004-06-01 16:01:33 EDT
[user1@hoho2 user1]$ man grip
No manual entry for grip
[user1@hoho2 user1]$ which grip
/usr/bin/which: no grip in
(/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/home/user1/bin)
[user1@hoho2 user1]$

[root@hoho2 user1]# yum install grip
...
Installed:  grip 1:3.0.7-4.i386
Transaction(s) Complete
[root@hoho2 user1]#

grip ----

I get the track listing (the record is "Future Sounds of Jazz - vol 5"
(my son has a track on that disk), the timer is going, the volume is
up, but no sound.
Comment 7 Bill Nottingham 2004-06-01 16:08:57 EDT
Oops, wrong app.

Go to xmms, choose 'Play Location', enter /mnt/cdrom.

You'll probably get the same 'silent' behavior here when playing.

Then, go to Options->Preferences. Select 'CD Audio Player' and
choose 'configure'. Switch it from 'Analog' to "Digital Audio
Extraction'. Does that yield volume?

Comment 8 Bob Gustafson 2004-06-01 16:32:19 EDT
With xmms, I get CD Track 01 - the timer is incrementing, but no sound.

Hmm, going to Preferences -> CD and DVD, I get an error dialog box
"The Application "gnome CD-properties unexpectedly quit"

Clicking the 'Restart" button makes the dialog go away, but nothing
else happens.

/var/log/messages for last while
[root@hoho2 log]# tail messages
Jun  1 13:30:59 hoho2 kernel: agpgart: Putting AGP V2 device at
0000:01:00.0 into 1x mode
Jun  1 13:30:59 hoho2 kernel: [drm] Loading R200 Microcode
Jun  1 13:30:59 hoho2 modprobe: FATAL: Error running install command
for sound_slot_1
Jun  1 13:31:03 hoho2 modprobe: FATAL: Error running install command
for sound_slot_1
Jun  1 13:34:42 hoho2 ntpd[2293]: synchronized to 66.187.233.4, stratum=1
Jun  1 13:34:42 hoho2 ntpd[2293]: kernel time sync disabled 0041
Jun  1 13:42:13 hoho2 ntpd[2293]: kernel time sync enabled 0001
Jun  1 14:54:30 hoho2 su(pam_unix)[3889]: session opened for user root
by user1(uid=500)
Jun  1 15:22:33 hoho2 kernel: hda: packet command error: status=0x51 {
DriveReady SeekComplete Error }
Jun  1 15:22:33 hoho2 kernel: hda: packet command error: error=0x50
[root@hoho2 log]#

The earlier messages are part of the boot sequence. The time now is
about 15:29  The 15:22 message may have been from the xmms.

No log file entry from the Preferences -> CD and DVD dialog box.

Comment 9 Bill Nottingham 2004-06-01 16:34:58 EDT
Argh, sorry. Options->Preferences *in xmms*. (Right click on the
upper-left of the titlebar should open the menu.)
Comment 10 Bob Gustafson 2004-06-01 17:00:33 EDT
OK, got it. When I click on the 'Check Drive' button (after switching
to Play Mode -> Digital Audio extraction, the CD Player (??) dialog
box opens (may have been coincidental - had play on insert checked)
and has track name and timer goes, but no sound.

Kill off CD Player window. XMMS disk check dialog window was up and
says disk is OK, and digital extraction is OK  (Disc has 9 tracks, etc.)

Closing test dialog, click APPLY and OK closes preferences box.

xmms is humming along, track is shown, timer is moving.

No sound yet.
Comment 11 Bill Nottingham 2004-06-01 17:32:29 EDT
Hm. Can you attach the output of the 'amixer' command?
Comment 12 Bob Gustafson 2004-06-01 21:06:16 EDT
Created attachment 100777 [details]
Output of amixer without any arguments
Comment 13 Bob Gustafson 2004-06-01 21:09:36 EDT
This is output with argument info

[root@hoho2 log]# amixer info
Card default 'I82801DBICH4'/'Intel 82801DB-ICH4 at 0xd0000c00, irq 177'
  Mixer name    : 'Realtek ALC650 rev 2'
  Components    : 'AC97a'
  Controls      : 51
  Simple ctrls  : 34
[root@hoho2 log]#

Harware browser confirms Intel chip - adds 'AC97' phrase

---- I will be 'unplugged' until next Monday - family vacation --
Comment 14 Bob Gustafson 2004-06-01 21:13:33 EDT
One other piece of information - there is no speaker in the box -
event sounds play through external speaker system - plugged into back
of box, not any card.
Comment 15 Bill Nottingham 2004-06-01 23:54:11 EDT
Hm, nothing looks wrong there in the config. If I had to say, it's
just that there's no cable from the CD-ROM to the motherboard for
sound. That doesn't explain why using digital extraction in xmms isn't
working for you, though.
Comment 16 Bob Gustafson 2004-07-08 15:02:31 EDT
So, I bought an audio cable last week and finally got around to
plugging it in a few minutes ago. It is a 6ft cable as it needs to
come from the jack on the front of the CD drive around to the back
where the Line-In jack is located.

Results - yep, I now get CD sound through the speakers. The volume
responds to the taskbar slider, the 'Volume' section and the 'Line-in'
section of the expanded 'Volume Control' dialog. Moving the 'CD'
slider has no effect on the music.

(currently playing 'The Alkan Project' - nice collection of short
piano pieces by composer Alkan, who was a neighbor of Chopin in Paris
and who died in 1888 - a bookcase fell on him)

----------

I upgraded most of my FC this morning and lots of things now work. I
will go back over the suggestions for getting digital sound out of the
CD player - maybe that works now??
Comment 17 Bob Gustafson 2004-07-08 15:22:52 EDT
Wow - put xmms in the Gnome 'Run Application' window, hit enter - and
it hung my system. Cursor stopped, no response to keyboard, network
lights steady - no blinking. Flat line. Power cycle to recover.

I guess xmms has not been upgraded as yet - udev and other features
probably missing.. Too bad.

[user1@hoho2 user1]$ cat /proc/version
Linux version 2.6.7-1.476smp (bhcompile@daffy.perf.redhat.com) (gcc
version 3.4.1 20040702 (Red Hat Linux 3.4.1-2)) #1 SMP Wed Jul 7
14:56:17 EDT 2004
[user1@hoho2 user1]$

Comment 18 Bill Nottingham 2004-07-08 15:32:11 EDT
Hm, if it hung the system, that's a new kernel bug, almost certainly.
Comment 19 Bob Gustafson 2004-07-11 12:59:15 EDT
Hey, cool

I went back to xmms (this is after updating kernel to -478smp) and
selected /mnt/cdrom in Play Location. Changing CD Player preferences
to Digial extraction, etc.

I also struggled with getting font sizes bigger. xmms does not respond
to Optiongs->preferences->fonts . I edited what I saw to bgger fonts
and it did not change - even after Apply and OK. Quiting xmms and
going back to that spot - at least what I had edited was still there.
 I probably need to spend more time - perhaps browsing to 'real' fonts..

Anyway, I quit xmms, plugged in the Alkan music disk and then started
up xmms.  The music began to play almost immediately, but then I saw
the regular Gnome CD Player on the screen - prefs there are that it
will start when a disk (music?) is inserted.

I swatted down the CD Player and then did the Play location selection
to /mnt/cdrom on xmms.  It played music !!.

And, what is really great is that when I unplugged the audio cable
from the front of the CD drive - THE MUSIC CONTINUED TO PLAY.

Great - thanks much.  Works for me.

(Would be nice if the Gnome CD Player had a digital extraction mode as
well as xmms. the fonts are so much better.)


Note You need to log in before you can comment on or make changes to this bug.