Bug 1247530 - snapper: perform 'restorecon' on .snapshots subvolume
snapper: perform 'restorecon' on .snapshots subvolume
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: snapper (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Kozina
Fedora Extras Quality Assurance
: FutureFeature
: 1301329 (view as bug list)
Depends On: 1247532
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-28 05:10 EDT by Ondrej Kozina
Modified: 2016-08-19 06:37 EDT (History)
8 users (show)

See Also:
Fixed In Version: snapper-0.3.3-1.fc25
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1069312
Environment:
Last Closed: 2016-08-19 06:37:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondrej Kozina 2015-07-28 05:10:25 EDT
Snapper needs a way how to set a proper selinux context on btrfs subvolumes originating in snapshot create command. Fs can't handle it on its own.

We've briefly outlined the future fix for this problem in Fedora. The fix will involve manually setting/restoring types for .snapshots directory content from within the snapperd.

Generally I need predefined source for types supposed to be set in .snapshots directory.
Comment 1 Jan Kurik 2016-02-24 10:50:12 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Ondrej Kozina 2016-03-03 07:02:04 EST
*** Bug 1301329 has been marked as a duplicate of this bug. ***
Comment 3 Ondrej Kozina 2016-04-12 09:28:21 EDT
Awaiting review from upstream: https://github.com/openSUSE/snapper/pull/239

Note You need to log in before you can comment on or make changes to this bug.