Bug 1247567 - Include (build) fixes for non-intel archs
Include (build) fixes for non-intel archs
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: docker (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lokesh Mandvekar
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker PPCTracker F-ExcludeArch-ppc64le/PPC64LETracker
  Show dependency treegraph
 
Reported: 2015-07-28 07:00 EDT by Jakub Čajka
Modified: 2015-08-04 12:50 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-04 12:50:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed fix (17.68 KB, patch)
2015-07-28 07:00 EDT, Jakub Čajka
no flags Details | Diff

  None (edit)
Description Jakub Čajka 2015-07-28 07:00:15 EDT
Created attachment 1056995 [details]
Proposed fix

Docker build fails on secondary archs due to missing constants in docker copy of netns. 

http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=2669639
http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=1923005

Current docker upstream contains fix for ppc64le(and arm64/arm32 but they seems to be part of big commit containing also forward port/rebase of libnetwork...) and upstream of netns contains (additional) fixes for arm32(incorrect syscall number), aarch64 and s390x.

I have prepared Fedora dist-git patch containing upstream docker commit with basic netns fixes, patch based on netns upstream fixes(with additional ppc64 defines) and changes to spec file due to changes in netns.

Please include this patches.
Comment 1 Lokesh Mandvekar 2015-08-04 12:50:09 EDT
fixed here: http://koji.fedoraproject.org/koji/buildinfo?buildID=672899

Note You need to log in before you can comment on or make changes to this bug.