Bug 1247611 - no (obvious?) way how to configure user data support for OpenStack image via hammer
no (obvious?) way how to configure user data support for OpenStack image via ...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity medium (vote)
: Beta
: --
Assigned To: Stephen Benjamin
Jitendra Yejare
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-28 08:30 EDT by Jan Hutař
Modified: 2016-07-27 04:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 04:54:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13852 None None None 2016-04-22 11:43 EDT

  None (edit)
Description Jan Hutař 2015-07-28 08:30:11 EDT
Description of problem:
There is no (obvious?) way how to configure user data support for OpenStack image via hammer


Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-6-20150721.7-Satellite-x86_64


How reproducible:
always


Steps to Reproduce:
1. Configure OpenStack compute resource
2. Infrastructure -> Compute resources -> <your_cr> -> Images -> [New Image]
   (or edit existing one)
   Note that there is a "User data" checkbox
3. Now check hammer command for this functionality:

# hammer --username 'admin' --password 'changeme' compute-resource image create -h
Usage:
    hammer compute-resource image create [OPTIONS]

Options:
 --architecture ARCHITECTURE_NAME          Architecture name
 --architecture-id ARCHITECTURE_ID          
 --compute-resource COMPUTE_RESOURCE_NAME  Compute resource name
 --compute-resource-id COMPUTE_RESOURCE_ID  
 --name NAME                                
 --operatingsystem OPERATINGSYSTEM_TITLE   Operating system title
 --operatingsystem-id OPERATINGSYSTEM_ID    
 --username USERNAME                        
 --uuid UUID                                
 -h, --help                                print help
# hammer --username 'admin' --password 'changeme' compute-resource image update -h
Usage:
    hammer compute-resource image update [OPTIONS]

Options:
 --architecture ARCHITECTURE_NAME          Architecture name
 --architecture-id ARCHITECTURE_ID          
 --compute-resource COMPUTE_RESOURCE_NAME  Compute resource name
 --compute-resource-id COMPUTE_RESOURCE_ID  
 --id ID                                    
 --name NAME                               Name to search by
 --new-name NEW_NAME                        
 --operatingsystem OPERATINGSYSTEM_TITLE   Operating system title
 --operatingsystem-id OPERATINGSYSTEM_ID    
 --username USERNAME                        
 --uuid UUID                                
 -h, --help                                print help


Actual results:
There is no way how to configure user data support


Expected results:
There should be a way
Comment 1 Jan Hutař 2015-07-28 08:43:16 EDT
Workaround which seems to work (with image already created):

curl -k -u <user>:<pass> -X PUT -d '{ "user_data":true }' -H 'Accept: application/json' -H 'Content-Type: application/json' https://<fqdn>/api/v2/compute_resources/<cr_id>/images/<image_id>
Comment 3 Stephen Benjamin 2016-02-23 10:15:50 EST
Created redmine issue http://projects.theforeman.org/issues/13852 from this bug
Comment 4 Bryan Kearney 2016-02-23 12:06:30 EST
Upstream bug assigned to stbenjam@redhat.com
Comment 5 Bryan Kearney 2016-02-23 12:06:33 EST
Upstream bug component is API
Comment 6 Bryan Kearney 2016-02-24 04:06:32 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/13852 has been closed
-------------
Anonymous
Applied in changeset commit:1cd4a22df2b4a34ea8a03150b1bd406494587ed3.
Comment 9 Jitendra Yejare 2016-04-15 10:20:38 EDT
Verified this issue in Sat 6.2 snap 8.1

The issue is no more reproducible. I see --user-data option added while creating and updating an image.

Evidence:
# hammer compute-resource image create -h
Usage:
    hammer compute-resource image create [OPTIONS]

Options:
 --architecture ARCHITECTURE_NAME          Architecture name
 --architecture-id ARCHITECTURE_ID          
 --compute-resource COMPUTE_RESOURCE_NAME  Compute resource name
 --compute-resource-id COMPUTE_RESOURCE_ID  
 --name NAME                                
 --operatingsystem OPERATINGSYSTEM_TITLE   Operating system title
 --operatingsystem-id OPERATINGSYSTEM_ID    
 --user-data USER_DATA                     Whether or not the image supports user data
                                           One of true/false, yes/no, 1/0.
 --username USERNAME                        
 --uuid UUID                                
 -h, --help                                print help


# hammer compute-resource image update -h
Usage:
    hammer compute-resource image update [OPTIONS]

Options:
 --architecture ARCHITECTURE_NAME          Architecture name
 --architecture-id ARCHITECTURE_ID          
 --compute-resource COMPUTE_RESOURCE_NAME  Compute resource name
 --compute-resource-id COMPUTE_RESOURCE_ID  
 --id ID                                    
 --name NAME                               Name to search by
 --new-name NEW_NAME                        
 --operatingsystem OPERATINGSYSTEM_TITLE   Operating system title
 --operatingsystem-id OPERATINGSYSTEM_ID    
 --user-data USER_DATA                     Whether or not the image supports user data
                                           One of true/false, yes/no, 1/0.
 --username USERNAME                        
 --uuid UUID                                
 -h, --help                                print help

# hammer compute-resource image update --user-data 1 --id 1 --compute-resource-id 10
Image updated
# hammer compute-resource image update --user-data 0 --id 1 --compute-resource-id 10
Image updated

So moving this to verified.
Comment 11 errata-xmlrpc 2016-07-27 04:54:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.