Bug 1247614 - removing log-collector package is remove important rhevm packages as well.
removing log-collector package is remove important rhevm packages as well.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-log-collector (Show other bugs)
3.5.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Sandro Bonazzola
Pavel Stehlik
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-28 08:36 EDT by Ulhas Surse
Modified: 2015-08-11 05:12 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-29 04:35:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulhas Surse 2015-07-28 08:36:42 EDT
Description of problem:
While removing a single "rhevm-log-collector" package with yum removed all important rhevm packages from the setup that causes environment crash.

  # yum remove rhevm-log-collector -y

Dependencies Resolved

===============================================================================================================================================================================================================
 Package                                                       Arch                             Version                                        Repository                                                 Size
===============================================================================================================================================================================================================
Removing:
 rhevm-log-collector                                           noarch                           3.5.3-2.el6ev                                  @rhel-x86_64-server-6-rhevm-3.5                           148 k
Removing for dependencies:
 ovirt-engine-extension-aaa-ldap                               noarch                           1.0.2-1.el6ev                                  @rhel-x86_64-server-6-rhevm-3.5                           171 k
 ovirt-engine-extension-aaa-misc                               noarch                           1.0.0-2.el6ev                                  @rhel-x86_64-server-6-rhevm-3.5                            19 k
 ovirt-engine-extension-logger-log4j                           noarch                           1.0.0-2.el6ev                                  @rhel-x86_64-server-6-rhevm-3.5                           5.6 k
 redhat-support-plugin-rhev                                    noarch                           3.5.0-1.el6ev                                  @rhel-x86_64-server-6-rhevm-3.5                            18 M
 rhevm                                                         noarch                           3.5.3.1-1.4.el6ev                              @rhel-x86_64-server-6-rhevm-3.5                           2.2 M
 rhevm-backend                                                 noarch                           3.5.3.1-1.4.el6ev                              @rhel-x86_64-server-6-rhevm-3.5                           4.9 M
 rhevm-dbscripts                                               noarch                           3.5.3.1-1.4.el6ev                              @rhel-x86_64-server-6-rhevm-3.5                           1.0 M
 rhevm-restapi                                                 noarch                           3.5.3.1-1.4.el6ev                              @rhel-x86_64-server-6-rhevm-3.5                           1.6 M
 rhevm-setup                                                   noarch                           3.5.3.1-1.4.el6ev                              @rhel-x86_64-server-6-rhevm-3.5                            44  
 rhevm-setup-plugin-ovirt-engine                               noarch                           3.5.3.1-1.4.el6ev                              @rhel-x86_64-server-6-rhevm-3.5                           687 k
 rhevm-setup-plugins                                           noarch                           3.5.1-2.el6ev                                  @rhel-x86_64-server-6-rhevm-3.5                            98 k
 rhevm-spice-client-x64-cab                                    noarch                           3.5-2.el6                                      @rhel-x86_64-server-6-rhevm-3.5                            15 M
 rhevm-spice-client-x64-msi                                    noarch                           3.5-2.el6                                      @rhel-x86_64-server-6-rhevm-3.5                            34 M
 rhevm-spice-client-x86-cab                                    noarch                           3.5-2.el6                                      @rhel-x86_64-server-6-rhevm-3.5                            14 M
 rhevm-spice-client-x86-msi                                    noarch                           3.5-2.el6                                      @rhel-x86_64-server-6-rhevm-3.5                            33 M
 rhevm-tools                                                   noarch                           3.5.3.1-1.4.el6ev                              @rhel-x86_64-server-6-rhevm-3.5                           268 k
 rhevm-userportal                                              noarch                           3.5.3.1-1.4.el6ev                              @rhel-x86_64-server-6-rhevm-3.5                           193 M
 rhevm-webadmin-portal                                         noarch                           3.5.3.1-1.4.el6ev                              @rhel-x86_64-server-6-rhevm-3.5                           280 M

Transaction Summary
===============================================================================================================================================================================================================
Remove       19 Package(s)


Version-Release number of selected component (if applicable):
rhevm-log-collector-3.5.3-2.el6ev
rhevm-3.5.3.1-1.4.el6ev

How reproducible:
Always 

Steps to Reproduce:
1. Try to remove rhevm-log-collector pacakge.
2. You will get all rhevm packages list to be removed.
3. 

Actual results:
Removed all important packages.

Expected results:
Should not remove important packages. atleast which should be there to run the rhevm setup.

Additional info:
Known alternative is

 1] rpm --nodeps -e rhevm-log-collector
Comment 1 Sandro Bonazzola 2015-07-29 04:35:37 EDT
Thanks for reporting. This is expected behavior for rhevm-log-collector, closing as not a bug.

Note You need to log in before you can comment on or make changes to this bug.