Bug 1247615 - tests/bugs/replicate/bug-1238508-self-heal.t fails in 3.7 branch
tests/bugs/replicate/bug-1238508-self-heal.t fails in 3.7 branch
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tests (Show other bugs)
3.7.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-28 08:39 EDT by Atin Mukherjee
Modified: 2015-09-09 05:38 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-09 05:38:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Atin Mukherjee 2015-07-28 08:39:44 EDT
Description of problem:

On release-3.7, tests/bugs/replicate/bug-1238508-self-heal.t seems
impossible to pass:

TEST 20 (line 33): 0 afr_get_pending_heal_count patchy
./tests/bugs/replicate/../../include.rc: line 270: afr_get_pending_heal_count: command not found

not ok 20 Got "" instead of "0"
RESULT 20: 1

Version-Release number of selected component (if applicable):
3.7
Comment 1 Anand Avati 2015-07-28 08:40:17 EDT
REVIEW: http://review.gluster.org/11776 (tests: Fix ./tests/bugs/replicate/bug-1238508-self-heal.t) posted (#1) for review on release-3.7 by Atin Mukherjee (amukherj@redhat.com)
Comment 2 Anand Avati 2015-07-29 03:06:45 EDT
COMMIT: http://review.gluster.org/11776 committed in release-3.7 by Kaushal M (kaushal@redhat.com) 
------
commit 382a6c00260d2a81cd596ca454768c78d61a14ee
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Tue Jul 7 12:15:17 2015 +0530

    tests: Fix ./tests/bugs/replicate/bug-1238508-self-heal.t
    
    backport of http://review.gluster.org/#/c/11556/
    
    Test failed @
    http://build.gluster.org/job/rackspace-regression-2GB-triggered/12010/consoleFull
    (Reported by Vijaykumar M)
    
    Fix:
    s/afr_get_pending_heal_count/get_pending_heal_count
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    
    Change-Id: I69c44919ae68e3ebb9a5bc58a8e45a0a96fad62e
    BUG: 1247615
    Reviewed-on: http://review.gluster.org/11556
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-on: http://review.gluster.org/11776
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>
Comment 3 Kaushal 2015-09-09 05:38:40 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.