Bug 1247617 - Inherited variable fields empty in 'edit host' / 'new host' screens
Summary: Inherited variable fields empty in 'edit host' / 'new host' screens
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Organizations and Locations
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Tomer Brisker
QA Contact: Jitendra Yejare
URL: http://projects.theforeman.org/issues...
Whiteboard: Verified in Upstream
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-28 12:44 UTC by Maxim Burgerhout
Modified: 2019-11-14 06:50 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:54:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot demonstrating issue (94.35 KB, image/png)
2015-07-28 12:45 UTC, Maxim Burgerhout
no flags Details
Failed QA - Screenshot (135.36 KB, image/png)
2015-09-01 09:29 UTC, Jitendra Yejare
no flags Details
Verified Screenshot (132.91 KB, image/png)
2015-09-07 09:45 UTC, Jitendra Yejare
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Maxim Burgerhout 2015-07-28 12:44:16 UTC
Description of problem:
I have nested locations in my Satellite 6.1.0 setup: Amsterdam, Amsterdam/DC01 and Amsterdam/DC02.

DC01 and DC02 inherit a time-zone variable from Amsterdam.

Though it works fine, the field that should show the value of the time-zone variable when creating a new host / editing an existing one, is empty. 

See attached screenshot.

Version-Release number of selected component (if applicable):
6.1.0 beta
foreman-1.7.2.32-1.el7sat.noarch


How reproducible:
Create nested locations, add variable to parent location, create new host in child location.

Steps to Reproduce:
1. Create nested locations
2. Add variable to parent location
3. Create new host in child location

Actual results:
Variable field is empty

Expected results:
Variable field should show variable value of parent location

Additional info:
I set the component to WebUI, because the correct value is actually in the YAML output: it's just not shown in the webui.

The screenshot explains this much better than I can.

Comment 1 Maxim Burgerhout 2015-07-28 12:45:45 UTC
Created attachment 1057012 [details]
Screenshot demonstrating issue

Screenshot showing empty field, should show 'Europe/Amsterdam' instead of empty box

Comment 3 Bryan Kearney 2015-08-14 17:53:16 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/7840 has been closed
-------------
Anonymous
Applied in changeset commit:33eca4dfec4949308aa265420b963cd80c5f7d13.

Comment 5 Jitendra Yejare 2015-09-01 09:29:46 UTC
Created attachment 1068903 [details]
Failed QA - Screenshot

Comment 6 Jitendra Yejare 2015-09-01 09:30:13 UTC
Verified this bug in upstream, the bug is still reproducible. So changing the state to Assigned/FailedQA.

Steps I followed:
1. Create two nested locations from 'Default Location'. i.e- Default Location/myLoc1 and Default Location/myLoc2.
2. Added variable parameter in 'Default-Location':
Name: 'time-zone', value: 'IST'
3. Creating new host in location 'Default Location/myLoc1'.

Observed:
Blank time-zone inherited variable from parent location.

Verified on versions:
foreman-proxy-1.10.0-0.develop.201508250705gitb446e0c.el7.noarch
foreman-release-1.10.0-0.develop.201508241946git8658fa3.el7.noarch
foreman-compute-1.10.0-0.develop.201508241946git8658fa3.el7.noarch
foreman-gce-1.10.0-0.develop.201508241946git8658fa3.el7.noarch
foreman-1.10.0-0.develop.201508241946git8658fa3.el7.noarch
foreman-release-scl-1-1.el7.x86_64

More:
Screenshot attached.

Comment 7 Bryan Kearney 2015-09-01 10:04:08 UTC
Upstream bug component is Provisioning

Comment 8 Bryan Kearney 2015-09-01 10:04:09 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/7840 has been closed
-------------
Anonymous
Applied in changeset commit:33eca4dfec4949308aa265420b963cd80c5f7d13.

Comment 9 Tomer Brisker 2015-09-02 06:56:13 UTC
Looks like the upstream bug that was linked was similar but not identical to this one. I will clone this to redmine and submit new PR to fix it.
Thank you Jitendra for noticing this!

Comment 10 Tomer Brisker 2015-09-02 06:56:54 UTC
Created redmine issue http://projects.theforeman.org/issues/11650 from this bug

Comment 11 Bryan Kearney 2015-09-02 10:04:08 UTC
Upstream bug component is Multi Org

Comment 12 Bryan Kearney 2015-09-03 08:04:13 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/11650 has been closed
-------------
Anonymous
Applied in changeset commit:be33e6e905c8d0315262a3a3a45459c3a098a29e.

Comment 13 Jitendra Yejare 2015-09-07 09:45:36 UTC
Created attachment 1070904 [details]
Verified Screenshot

Comment 14 Jitendra Yejare 2015-09-07 09:45:49 UTC
Verified this in latest upstream.

The inherited field value is displayed properly for the variable.

Build:

foreman-1.10.0-0.develop.201509041547git84f7fc6.el7.noarch

Screenshot attached.

Comment 15 Jitendra Yejare 2015-09-07 09:46:17 UTC
Verified this in latest upstream.

The inherited field value is displayed properly for the variable.

Build:

foreman-1.10.0-0.develop.201509041547git84f7fc6.el7.noarch

Screenshot attached.

Comment 16 Karl Abbott 2015-12-21 19:57:20 UTC
Is there any chance of getting this in 6.1.z ? 

Karl

Comment 22 errata-xmlrpc 2016-07-27 08:54:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.