Bug 1247636 - When running katello-service stop foreman-proxy is still running on satellite 6.0.8
When running katello-service stop foreman-proxy is still running on satellite...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Other (Show other bugs)
6.0.8
Unspecified Unspecified
unspecified Severity medium (vote)
: Beta
: --
Assigned To: Brad Buckingham
Corey Welton
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-28 09:54 EDT by jnikolak
Modified: 2016-07-27 04:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 04:54:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 08:24:38 EDT

  None (edit)
Description jnikolak 2015-07-28 09:54:26 EDT
I ran 

katello-service stop

# katello-service stop
Shutting down Katello services...
Stopping httpd:                                            [  OK  ]
celery init v10.0.
Using configuration: /etc/default/pulp_workers, /etc/default/pulp_celerybeat
Stopping pulp_celerybeat... OK
celery init v10.0.
Using config script: /etc/default/pulp_workers
celery multi v3.1.11 (Cipater)
> Stopping nodes...
	> reserved_resource_worker-1@jnikolaksat6rhel6.gsslab.pek.redhat.com: TERM -> 2282
	> reserved_resource_worker-5@jnikolaksat6rhel6.gsslab.pek.redhat.com: TERM -> 2374
	> reserved_resource_worker-7@jnikolaksat6rhel6.gsslab.pek.redhat.com: TERM -> 2423
	> reserved_resource_worker-4@jnikolaksat6rhel6.gsslab.pek.redhat.com: TERM -> 2351
	> reserved_resource_worker-6@jnikolaksat6rhel6.gsslab.pek.redhat.com: TERM -> 2400
	> reserved_resource_worker-2@jnikolaksat6rhel6.gsslab.pek.redhat.com: TERM -> 2306
	> reserved_resource_worker-0@jnikolaksat6rhel6.gsslab.pek.redhat.com: TERM -> 2263
	> reserved_resource_worker-3@jnikolaksat6rhel6.gsslab.pek.redhat.com: TERM -> 2332
> Waiting for 8 nodes -> 2282, 2374, 2423, 2351, 2400, 2306, 2263, 2332............
	> reserved_resource_worker-1@jnikolaksat6rhel6.gsslab.pek.redhat.com: OK
> Waiting for 7 nodes -> 2374, 2423, 2351, 2400, 2306, 2263, 2332....
	> reserved_resource_worker-5@jnikolaksat6rhel6.gsslab.pek.redhat.com: OK
> Waiting for 6 nodes -> 2423, 2351, 2400, 2306, 2263, 2332....
	> reserved_resource_worker-7@jnikolaksat6rhel6.gsslab.pek.redhat.com: OK
> Waiting for 5 nodes -> 2351, 2400, 2306, 2263, 2332....
	> reserved_resource_worker-4@jnikolaksat6rhel6.gsslab.pek.redhat.com: OK
> Waiting for 4 nodes -> 2400, 2306, 2263, 2332....
	> reserved_resource_worker-6@jnikolaksat6rhel6.gsslab.pek.redhat.com: OK
> Waiting for 3 nodes -> 2306, 2263, 2332....
	> reserved_resource_worker-2@jnikolaksat6rhel6.gsslab.pek.redhat.com: OK
> Waiting for 2 nodes -> 2263, 2332....
	> reserved_resource_worker-0@jnikolaksat6rhel6.gsslab.pek.redhat.com: OK
> Waiting for 1 node -> 2332....
	> reserved_resource_worker-3@jnikolaksat6rhel6.gsslab.pek.redhat.com: OK

celery init v10.0.
Using config script: /etc/default/pulp_resource_manager
celery multi v3.1.11 (Cipater)
> Stopping nodes...
	> resource_manager@jnikolaksat6rhel6.gsslab.pek.redhat.com: TERM -> 2202
> Waiting for 1 node -> 2202.....
	> resource_manager@jnikolaksat6rhel6.gsslab.pek.redhat.com: OK

Stopping elasticsearch:                                    [  OK  ]
Stopping Qpid AMQP daemon:                                 [  OK  ]
Stopping mongod:                                           [  OK  ]
Stopping tomcat6:                                          [  OK  ]
Done.



There doesn't appear to be any option to have foreman-proxy stopped.


After running

ps aux | grep foreman-proxy
495       1677  0.2  0.6 161260 53168 ?        Sl   09:37   0:01 /usr/bin/ruby /usr/share/foreman-proxy/bin/smart-proxy
root      3470  0.0  0.0 103252   836 pts/0    S+   09:48   0:00 grep foreman-proxy


I still see the foreman-proxy running


I can close this off with
service foreman-proxy stop


Is this issue fixed in satellite 6.1 at it could affect customers who want to re-provision servers.
Comment 2 Brad Buckingham 2015-09-02 14:53:36 EDT
I have tested this on a Satellite 6.1.1 GA install and am no longer observing
the behavior described.  'foreman-proxy' is now stopped as part of the katello-service command.

RPMs:
ruby193-rubygem-katello-2.2.0.66-1.el7sat.noarch
foreman-1.7.2.34-1.el7sat.noarch
Comment 3 jnikolak 2015-09-16 03:35:20 EDT
I'm still seeing the same issue on satellite 6.1.1
It was upgraded from Satellite 6.0.x


# katello-service stop
.....
celery init v10.0.
Using configuration: /etc/default/pulp_workers, /etc/default/pulp_celerybeat
Stopping pulp_celerybeat... OK
Stopping elasticsearch:                                    [  OK  ]
Stopping foreman-proxy:                                    [  OK  ]

Stopping httpd:                                            [  OK  ]
Success!
[root@jnikolaksat6rhel6 foreman-proxy]# ps aux | grep foreman-proxy
495       2246  0.2  0.6 162852 53980 ?        Sl   Sep15   3:20 ruby /usr/share/foreman-proxy/bin/smart-proxy
root      4247  0.0  0.0 103312   856 pts/0    S+   17:30   0:00 grep foreman-proxy
Comment 5 Tazim Kolhar 2016-04-03 02:26:16 EDT
VERIFIED:
# rpm -qa foreman
foreman-1.11.0.9-1.el7sat.noarch

Steps:
# katello-service stop
Redirecting to /bin/systemctl stop  foreman-tasks.service

Redirecting to /bin/systemctl stop  httpd.service

Redirecting to /bin/systemctl stop  pulp_workers.service

Redirecting to /bin/systemctl stop  pulp_resource_manager.service

Redirecting to /bin/systemctl stop  pulp_celerybeat.service

Redirecting to /bin/systemctl stop  foreman-proxy.service

Redirecting to /bin/systemctl stop  tomcat.service

Redirecting to /bin/systemctl stop  qdrouterd.service

Redirecting to /bin/systemctl stop  qpidd.service

Redirecting to /bin/systemctl stop  postgresql.service

Redirecting to /bin/systemctl stop  mongod.service

Success!

# ps aux | grep foreman-proxy
root     22917  0.0  0.0 112640   968 pts/0    S+   08:25   0:00 grep --color=auto foreman-proxy
Comment 8 errata-xmlrpc 2016-07-27 04:54:17 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.