Bug 124764 - python 2.3.4 is released
python 2.3.4 is released
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Brock Organ
http://www.python.org/2.3.4/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-29 13:02 EDT by Robert Scheck
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.3.4-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-10 10:13:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
python-2.3.4-lib64-regex.patch (814 bytes, patch)
2004-05-29 13:03 EDT, Robert Scheck
no flags Details | Diff

  None (edit)
Description Robert Scheck 2004-05-29 13:02:31 EDT
Description of problem:
This is a bug-fix release for Python 2.3 that fixes a number of bugs, 
including a couple of weakref bugs and a bug in pickle version 2. 
There are also a number of fixes to the standard library, and some 
build fixes - see the release notes for details:
http://www.python.org/2.3.4/NEWS.html

Version-Release number of selected component (if applicable):
python-2.3.3-6

Actual results:
The following upgrade works for me, that's what I did:

--- snipp ---
--- python.spec       2004-05-08 16:52:53.000000000 +0200
+++ python.spec.rsc   2004-05-29 19:00:08.000000000 +0200
@@ -12,8 +12,8 @@

 Summary: An interpreted, interactive, object-oriented programming language.
 Name: %{python}
-Version: %{pybasever}.3
-Release: 6
+Version: %{pybasever}.4
+Release: 1
 License: PSF - see LICENSE
 Group: Development/Languages
 Provides: python-abi = %{pybasever}
@@ -26,11 +26,9 @@
 Patch0: python-2.3-config.patch
 Patch3: Python-2.2.1-pydocnogui.patch
 Patch4: python-2.3-nowhatsnew.patch
-Patch7: python-2.3.3-lib64-regex.patch
+Patch7: python-2.3.4-lib64-regex.patch
 Patch8: python-2.3.2-lib64.patch
 Patch9: japanese-codecs-lib64.patch
-Patch10: python-2.2.2-urllib2-nonanonftp.patch
-Patch11: python-2.2.2-ftpuri.patch
 Patch12: python-2.3.2-nomkhowto.patch

 %if !%{aspython2}
@@ -151,12 +149,10 @@
 %patch3 -p1 -b .no_gui
 %patch4 -p1
 %if %{_lib} == lib64
-%patch7 -p0 -b .lib64-regex
+%patch7 -p1 -b .lib64-regex
 %patch8 -p1 -b .lib64
 %patch9 -p0 -b .lib64-j
 %endif
-%patch10 -p1 -b .nonanonftp
-%patch11 -p1 -b .ftpuri
 %patch12 -p1 -b .nomkhowto

 # This shouldn't be necesarry, but is right now (2.2a3)
--- snapp ---

Expected results:
Upgrade to 2.3.4 :)

Additional info:
Patch 10 and 11 are already in upstream, so I removed them. Patch 7
is in parts in upstream, so I merged the missing test back to 2.3.4.
Comment 1 Robert Scheck 2004-05-29 13:03:12 EDT
Created attachment 100696 [details]
python-2.3.4-lib64-regex.patch
Comment 2 Mihai Ibanescu 2004-06-04 17:56:03 EDT
Thanks for the patch. Package is in the latest rawhide.
Comment 3 Robert Scheck 2004-06-10 10:13:23 EDT
Okay, works for me - thank you :)

Note You need to log in before you can comment on or make changes to this bug.