Bug 1247655 - SCVMM - VM CPU Count shows 0 in UI
SCVMM - VM CPU Count shows 0 in UI
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity medium
: GA
: 5.4.2
Assigned To: Greg Blomquist
Thom Carlin
: ZStream
Depends On: 1210657
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-28 10:21 EDT by Chris Pelland
Modified: 2015-09-09 09:09 EDT (History)
14 users (show)

See Also:
Fixed In Version: 5.4.2.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1210657
Environment:
Last Closed: 2015-09-09 08:26:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 5 CFME Bot 2015-08-17 22:26:48 EDT
New commit detected on manageiq/master:
https://github.com/ManageIQ/manageiq/commit/be379d0dc793010fd9834b38cb277813069f99d9

commit be379d0dc793010fd9834b38cb277813069f99d9
Author:     Greg Blomquist <gblomqui@redhat.com>
AuthorDate: Fri Aug 14 16:41:03 2015 -0400
Commit:     Greg Blomquist <gblomqui@redhat.com>
CommitDate: Fri Aug 14 16:41:03 2015 -0400

    [SCVMM] Parse CPUCount into logical_cpus
    
    The UI (and other places) use Vm#logical_cpus to indicate the number of CPUs
    available in a VM.  Numbers like Vm#hardware#numvcpus and
    Vm#hardware#cores_per_socket help determine how Vm#logical_cpus is calculated.
    
    However, in the case of SCVMM there is only on CPUCount value returned when
    collecting inventory.  So, defaulting this value to logical_cpus will at least
    show the number of CPUs the Vm has available even if the constituent parts are
    not known.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1210657
    https://bugzilla.redhat.com/show_bug.cgi?id=1247655

 app/models/ems_refresh/parsers/scvmm.rb                    | 4 ++--
 spec/models/ems_refresh/refreshers/scvmm_refresher_spec.rb | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)
Comment 6 CFME Bot 2015-08-18 18:07:51 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=7ae15842cb984523dcb688da31602793d6336d81

commit 7ae15842cb984523dcb688da31602793d6336d81
Author:     Greg Blomquist <gblomqui@redhat.com>
AuthorDate: Fri Aug 14 16:41:03 2015 -0400
Commit:     Greg Blomquist <gblomqui@redhat.com>
CommitDate: Tue Aug 18 13:28:53 2015 -0400

    [SCVMM] Parse CPUCount into logical_cpus
    
    The UI (and other places) use Vm#logical_cpus to indicate the number of CPUs
    available in a VM.  Numbers like Vm#hardware#numvcpus and
    Vm#hardware#cores_per_socket help determine how Vm#logical_cpus is calculated.
    
    However, in the case of SCVMM there is only on CPUCount value returned when
    collecting inventory.  So, defaulting this value to logical_cpus will at least
    show the number of CPUs the Vm has available even if the constituent parts are
    not known.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1210657
    https://bugzilla.redhat.com/show_bug.cgi?id=1247655

 vmdb/app/models/ems_refresh/parsers/scvmm.rb                    | 4 ++--
 vmdb/spec/models/ems_refresh/refreshers/scvmm_refresher_spec.rb | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)
Comment 7 CFME Bot 2015-08-18 18:09:13 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=7ae15842cb984523dcb688da31602793d6336d81

commit 7ae15842cb984523dcb688da31602793d6336d81
Author:     Greg Blomquist <gblomqui@redhat.com>
AuthorDate: Fri Aug 14 16:41:03 2015 -0400
Commit:     Greg Blomquist <gblomqui@redhat.com>
CommitDate: Tue Aug 18 13:28:53 2015 -0400

    [SCVMM] Parse CPUCount into logical_cpus
    
    The UI (and other places) use Vm#logical_cpus to indicate the number of CPUs
    available in a VM.  Numbers like Vm#hardware#numvcpus and
    Vm#hardware#cores_per_socket help determine how Vm#logical_cpus is calculated.
    
    However, in the case of SCVMM there is only on CPUCount value returned when
    collecting inventory.  So, defaulting this value to logical_cpus will at least
    show the number of CPUs the Vm has available even if the constituent parts are
    not known.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1210657
    https://bugzilla.redhat.com/show_bug.cgi?id=1247655

 vmdb/app/models/ems_refresh/parsers/scvmm.rb                    | 4 ++--
 vmdb/spec/models/ems_refresh/refreshers/scvmm_refresher_spec.rb | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)
Comment 8 CFME Bot 2015-08-18 18:11:44 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=7ae15842cb984523dcb688da31602793d6336d81

commit 7ae15842cb984523dcb688da31602793d6336d81
Author:     Greg Blomquist <gblomqui@redhat.com>
AuthorDate: Fri Aug 14 16:41:03 2015 -0400
Commit:     Greg Blomquist <gblomqui@redhat.com>
CommitDate: Tue Aug 18 13:28:53 2015 -0400

    [SCVMM] Parse CPUCount into logical_cpus
    
    The UI (and other places) use Vm#logical_cpus to indicate the number of CPUs
    available in a VM.  Numbers like Vm#hardware#numvcpus and
    Vm#hardware#cores_per_socket help determine how Vm#logical_cpus is calculated.
    
    However, in the case of SCVMM there is only on CPUCount value returned when
    collecting inventory.  So, defaulting this value to logical_cpus will at least
    show the number of CPUs the Vm has available even if the constituent parts are
    not known.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1210657
    https://bugzilla.redhat.com/show_bug.cgi?id=1247655

 vmdb/app/models/ems_refresh/parsers/scvmm.rb                    | 4 ++--
 vmdb/spec/models/ems_refresh/refreshers/scvmm_refresher_spec.rb | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)
Comment 10 Thom Carlin 2015-08-26 10:24:45 EDT
Still see error in 5.4.2.0.20150820153254_83e434d
Comment 11 Greg Blomquist 2015-08-27 10:53:46 EDT
This is one of those annoying bugs where two things have happened to make this confusing:

1) This is a backport clone and a lot of the discussion continued on the previous bug.

2) The original report led to uncovering an different bug that could actually be fixed.

The original problem of "I see an error in the logs" was discarded as:

a) it's a real error, you really do need to have Virtual Guest Services installed, and

b) it's an ugly error and we will attempt to fix that

This morphed into realizing that the CPU Count always shows 0 for SCVMM VMs.

I changed the title of the upstream bug after the discussion went down this path, and really should have just opened a new bug at this point.

The bug that I fixed was that the CPU Count shows 0.  The ugly error has *not* been fixed and was not targeted here.
Comment 13 Thom Carlin 2015-08-27 11:01:38 EDT
Other issues are tied to API limitations.  As such, Verified.
Comment 15 errata-xmlrpc 2015-09-09 08:26:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1744.html

Note You need to log in before you can comment on or make changes to this bug.