Bug 124769 - Installer hangs when installing grub on XFS partitions
Installer hangs when installing grub on XFS partitions
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-29 15:13 EDT by Pedro Fernandes Macedo
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-01 16:20:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pedro Fernandes Macedo 2004-05-29 15:13:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040113

Description of problem:
If you try to install on a xfs partition , everything goes ok. After
all packages are installed , anaconda hangs on "Installing boot loader". 
Switching to the virtual terminals show grub has been run , but didnt
finish. Running top on vt2 shows grub using 99% of the CPU.

Doing a killall -TERM grub enables the installation to finish properly. 
(after killing grub , I did a chroot /mnt/sysimage ;
/sbin/grub-install /dev/hda  and it worked perfectly).

Version-Release number of selected component (if applicable):
grub-0.94-5

How reproducible:
Always

Steps to Reproduce:
1. Install on a XFS partition
2. Wait for the package installation to finish.  
3. 
    

Actual Results:  Installation hangs waiting for grub to finish. (It
hangs showing the "Installing bootloader" screen)

Expected Results:  Install shouldnt hang.

Additional info:

This bug has been confirmed with at least two other people.
Comment 1 Jeremy Katz 2004-06-01 16:06:11 EDT
Eric -- any thoughts or insights?
Comment 2 Eric Sandeen 2004-06-01 16:18:27 EDT
I'm guessing that this is still a problem with the fact that grub
expects the same view of bits via the raw device and via the filesystem.

Grub copies stuff through the xfs filesystem, then expects to go off
and read the device directly with it's own xfs filesystem smarts.

IIRC I've seen grub get into an infinite loop when the view through
the raw device was not in sync, essentially meaning that the
filesystem "looked" corrupt and grub got off in the weeds.

FC2/anaconda had some attempts to really freeze and sync the
filesystem so that all bits were really viewable via the raw device,
but looks like maybe there is still a window there.

I really should go talk to the grub folks; this seems like a
fundamental grub problem, although I'm not sure why xfs is so good at
hitting it  :)
Comment 3 Jeremy Katz 2004-06-01 16:39:48 EDT
Yeah, that was all I could think of as well -- I have added the bits
to freeze/thaw as should be appropriate, so I'm not quite sure why
that's not enough.
Comment 4 Pedro Fernandes Macedo 2004-07-19 18:52:19 EDT
Just to add some info. Just installed FC3T1 and this problem still
happens.. Had to kill grub and then reinstall it (both grub-install
and running root (hd0,0) , setup (hd0) inside grub worked)
Also , found a duplicate bug on the same subject: 117776 (there's also
117968 , but it has been closed as "rawhide")
Comment 5 Valentin Guggiana 2004-09-21 16:41:21 EDT
I just installed FC3test2 and the problem still exists.
Comment 6 Matthew Miller 2005-04-26 11:15:39 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.

Note You need to log in before you can comment on or make changes to this bug.