Bug 1247690 - No providers listed when Quota is assigned
No providers listed when Quota is assigned
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.3.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.5.0
Assigned To: Tina Fitzgerald
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-28 11:38 EDT by Aziza Karol
Modified: 2015-11-11 15:16 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-27 14:33:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
no providers (41.44 KB, image/png)
2015-07-28 11:38 EDT, Aziza Karol
no flags Details

  None (edit)
Description Aziza Karol 2015-07-28 11:38:52 EDT
Created attachment 1057056 [details]
no providers

Description of problem:


Version-Release number of selected component (if applicable):
5.4.1

How reproducible:
100%

Steps to Reproduce:
1. Add infra providers 
2.create a new group with role "EvmRole-administrator" and and set tag "Quota-max memory" to 2GB
3.create a new user base on above group
4.login with the above user

Actual results:
No providers are listed when Quota is assigned

Expected results:
Providers should be displayed

Additional info:
Comment 2 Gregg Tanzillo 2015-07-28 17:00:47 EDT
By assigning the tag Quota-max memory /2GB to the group it will restrict users of that group to see only object that have that tag assigned. In this case the provider does not have that tag assigned so the user in the new group is not authorized to see it.

If you go and assign that same tag to the provider the new user will be able to see it. It seems to be working as expected.
Comment 3 Dave Johnson 2015-07-30 11:45:58 EDT
Thanks for the clarification Greg...  Aziza, please retest.
Comment 4 Aziza Karol 2015-08-03 04:06:16 EDT
Thanks for clarification Greg. 

Its working as expected.But do we have this documented in our docs?

~Thanks,
Aziza
Comment 5 Tina Fitzgerald 2015-08-27 14:33:27 EDT
Hi Aziza,

I didn't realize that we're supposed to use the company tags to setup the quota values, so the information I gave you was incorrect for step 2 above:

The company tags don't affect access.

Sorry for the confusion.

Thanks,
Tina

Note You need to log in before you can comment on or make changes to this bug.