Bug 1247737 - turbostat 1.2-7 man page verbose flag incorrect
turbostat 1.2-7 man page verbose flag incorrect
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cpupowerutils (Show other bugs)
6.7
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Neil Horman
Erik Hamera
:
Depends On:
Blocks: 1172231 1269638 1270066
  Show dependency treegraph
 
Reported: 2015-07-28 13:46 EDT by Matthew Whitehead
Modified: 2016-05-10 16:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:29:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
new turbostat man page (11.10 KB, text/plain)
2015-07-31 15:08 EDT, Neil Horman
no flags Details

  None (edit)
Description Matthew Whitehead 2015-07-28 13:46:33 EDT
Description of problem: upgrading to turbostat 1.2-7 in RHEL6.7 changed the -v flag from 'verbose' to 'version', but the man page was not updated.


Version-Release number of selected component (if applicable): upgrading from turbostat 1.2-5 to 1.2-7

How reproducible: 100%


Steps to Reproduce:
1. run 'turbostat -v', it will return the version information, not put the command in verbose mode.

Actual results:

Below is a partial diff of the changed code:

+               case 'D':
+                       dump_only++;
                        break;
-               case 'v':
-                       verbose++;
+               case 'd':
+                       debug++;
                        break;

...

-               default:
-                       usage();
+               case 'v':
+                       print_version();
+                       exit(0);
+                       break


Expected results:

Man page should reflect program behavior.

Additional info:
Comment 2 Neil Horman 2015-07-28 16:25:37 EDT
way too late for 6.7, needs to wait for 6.8
Comment 3 Frank Hirtz 2015-07-28 17:16:27 EDT
Heh, we just had a mid-air collision as I was setting the flags for 6.8. That should be fine.
Comment 4 Neil Horman 2015-07-31 15:08:11 EDT
Created attachment 1058111 [details]
new turbostat man page

Dow that look about right to you Frank?
Comment 5 Matthew Whitehead 2015-08-18 15:24:27 EDT
Looks correct to me. Too bad they removed the 'verbose' flag completely.
Comment 6 Neil Horman 2015-08-18 16:19:02 EDT
ok, I'll commit this if it gets approved for 6.8
Comment 7 Frank Hirtz 2015-10-27 15:34:31 EDT
ACK, it looks fine to me.
Comment 9 Erik Hamera 2016-03-10 11:18:39 EST
Hi Neil,
there is no '-v' parameter mentioned neither in the man page nor in turbostat --help output. So is isn't misleading now.

My personal opinion is, that all existing parameters should be described in the man page. OTOH I can accept is as deprecated parameter and let is pass.

What do you think about?
Comment 10 Erik Hamera 2016-03-10 11:19:32 EST
# turbostat --help 2>&1|grep -- '-v'
--version       print version information
# man turbostat|grep -- '-v'
       --version displays the version.
# turbostat -v sleep 1
turbostat version 4.8 26-Sep, 2015 - Len Brown <lenb@kernel.org>
Comment 11 Neil Horman 2016-03-14 10:41:32 EDT
yes, please accept it as deprecated
Comment 12 Erik Hamera 2016-03-14 15:14:11 EDT
O.K., thanks for the info.
Comment 14 errata-xmlrpc 2016-05-10 16:29:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0785.html

Note You need to log in before you can comment on or make changes to this bug.