Bug 1247753 - [abrt] PackageKit: hy_repo_get_string(): packagekitd killed by SIGSEGV
[abrt] PackageKit: hy_repo_get_string(): packagekitd killed by SIGSEGV
Status: CLOSED DUPLICATE of bug 1135740
Product: Fedora
Classification: Fedora
Component: hawkey (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:61256160487a82538dd6d1dc322...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-28 14:49 EDT by Adam Williamson
Modified: 2015-08-11 07:53 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-11 07:50:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (15.71 KB, text/plain)
2015-07-28 14:49 EDT, Adam Williamson
no flags Details
File: cgroup (200 bytes, text/plain)
2015-07-28 14:49 EDT, Adam Williamson
no flags Details
File: core_backtrace (10.86 KB, text/plain)
2015-07-28 14:49 EDT, Adam Williamson
no flags Details
File: dso_list (7.17 KB, text/plain)
2015-07-28 14:49 EDT, Adam Williamson
no flags Details
File: environ (209 bytes, text/plain)
2015-07-28 14:49 EDT, Adam Williamson
no flags Details
File: limits (1.29 KB, text/plain)
2015-07-28 14:49 EDT, Adam Williamson
no flags Details
File: maps (34.29 KB, text/plain)
2015-07-28 14:49 EDT, Adam Williamson
no flags Details
File: mountinfo (4.28 KB, text/plain)
2015-07-28 14:49 EDT, Adam Williamson
no flags Details
File: namespaces (85 bytes, text/plain)
2015-07-28 14:49 EDT, Adam Williamson
no flags Details
File: open_fds (2.40 KB, text/plain)
2015-07-28 14:49 EDT, Adam Williamson
no flags Details
File: proc_pid_status (978 bytes, text/plain)
2015-07-28 14:49 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2015-07-28 14:49:04 EDT
Description of problem:
Seems to occur regularly in the background; I suspect it occurs when GNOME attempts to check for updates, and this is why we're not seeing update notifications on F23.

Note: F23 packages are not currently 100% signed, which I guess could conceivably be related.

Version-Release number of selected component:
PackageKit-1.0.7-1.fc23

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/libexec/packagekitd
crash_function: hy_repo_get_string
executable:     /usr/libexec/packagekitd
global_pid:     2369
kernel:         4.2.0-0.rc3.git3.1.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 hy_repo_get_string at /usr/src/debug/hawkey-0.5.9/py3/src/repo.c:200
 #1 load_yum_repo at /usr/src/debug/hawkey-0.5.9/py3/src/sack.c:552
 #2 hy_sack_load_repo at /usr/src/debug/hawkey-0.5.9/py3/src/sack.c:999
 #3 hy_sack_load_yum_repo at /usr/src/debug/hawkey-0.5.9/py3/src/sack.c:992
 #4 hif_sack_add_source at hif-sack.c:148
 #5 hif_sack_add_sources at hif-sack.c:201
 #6 hif_utils_add_remote at pk-backend-hif.c:490
 #7 hif_utils_create_sack_for_filters at pk-backend-hif.c:686
 #8 pk_backend_search_thread at pk-backend-hif.c:909
 #9 pk_backend_job_thread_setup at pk-backend-job.c:815
Comment 1 Adam Williamson 2015-07-28 14:49:18 EDT
Created attachment 1057095 [details]
File: backtrace
Comment 2 Adam Williamson 2015-07-28 14:49:20 EDT
Created attachment 1057096 [details]
File: cgroup
Comment 3 Adam Williamson 2015-07-28 14:49:22 EDT
Created attachment 1057097 [details]
File: core_backtrace
Comment 4 Adam Williamson 2015-07-28 14:49:24 EDT
Created attachment 1057098 [details]
File: dso_list
Comment 5 Adam Williamson 2015-07-28 14:49:27 EDT
Created attachment 1057099 [details]
File: environ
Comment 6 Adam Williamson 2015-07-28 14:49:32 EDT
Created attachment 1057100 [details]
File: limits
Comment 7 Adam Williamson 2015-07-28 14:49:35 EDT
Created attachment 1057101 [details]
File: maps
Comment 8 Adam Williamson 2015-07-28 14:49:37 EDT
Created attachment 1057102 [details]
File: mountinfo
Comment 9 Adam Williamson 2015-07-28 14:49:38 EDT
Created attachment 1057103 [details]
File: namespaces
Comment 10 Adam Williamson 2015-07-28 14:49:40 EDT
Created attachment 1057104 [details]
File: open_fds
Comment 11 Adam Williamson 2015-07-28 14:49:45 EDT
Created attachment 1057105 [details]
File: proc_pid_status
Comment 12 Adam Williamson 2015-07-28 15:08:18 EDT
This looks like it's actually in hawkey, so re-assigning.
Comment 13 Radek Holy 2015-08-11 07:50:19 EDT

*** This bug has been marked as a duplicate of bug 1135740 ***
Comment 14 Michal Luscon 2015-08-11 07:53:53 EDT
This looks like multi-threading issue, since the repo had been already freed when hawkey tried to dereference it.

hy_repo_get_string (repo=repo@entry=0x0, which=which@entry=0)

Note You need to log in before you can comment on or make changes to this bug.