Bug 1247777 - fix date-time rendering to use a pre-defined format that will fit all locales
fix date-time rendering to use a pre-defined format that will fit all locales
Status: CLOSED DUPLICATE of bug 1247776
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
3.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.6.0
Assigned To: Alexander Wels
Pavel Stehlik
ux
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-28 16:43 EDT by Einav Cohen
Modified: 2016-02-10 14:47 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-29 07:42:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Einav Cohen 2015-07-28 16:43:25 EDT
right now, we are using two hard-coded formats that we defined for rendering date-time values for Japanese, and for non-Japanese locales:

- "yyyy-MM-dd, HH:mm" for Japanese.

- "yyyy-MMM-dd, HH:mm" for all other locales. 

we should not write and maintain our own logic for manipulating date-time formats per locale - we should use a predefined date-time format that will take care of the manipulation for us. 

following Alexander's suggestion in https://gerrit.ovirt.org/#/c/42875/: I recommend going over all pre-defined date-time formats in [1], looking for the one that renders "yyyy-MMM-dd, HH:mm" (or something very close to it) in the 'en-US' locale, and go with that format for all locales - and, IIUC, the format will adjust itself properly for every locale. 

[1] http://www.gwtproject.org/javadoc/latest/com/google/gwt/i18n/client/DateTimeFormat.PredefinedFormat.html
Comment 1 Einav Cohen 2015-07-29 07:42:47 EDT

*** This bug has been marked as a duplicate of bug 1247776 ***

Note You need to log in before you can comment on or make changes to this bug.