Bug 1247779 - The Help button in the initial-setup GUI does not provide any help
The Help button in the initial-setup GUI does not provide any help
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda-user-help (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Martin Kolman
Release Test Team
:
Depends On: 1260071
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-28 16:46 EDT by Sean Toner
Modified: 2015-11-19 06:41 EST (History)
6 users (show)

See Also:
Fixed In Version: anaconda-user-help-7.2.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 06:41:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Shows help dialog with no help info (392.60 KB, image/png)
2015-07-28 16:46 EDT, Sean Toner
no flags Details
Shows help dialog with no help info (166.97 KB, image/png)
2015-07-28 16:51 EDT, Sean Toner
no flags Details

  None (edit)
Description Sean Toner 2015-07-28 16:46:01 EDT
Created attachment 1057121 [details]
Shows help dialog with no help info

Description of problem:
=======================

If you click on the Help button in any stage of the initial-setup, it says there is no information for this screen

(see screenshot)


Version-Release number of selected component (if applicable):
=============================================================

[root@rhel7-2-test-stoner ~]# rpm -qa | grep initial
initial-setup-gui-0.3.9.26-2.el7.x86_64
subscription-manager-initial-setup-addon-1.15.6-1.el7.x86_64
gnome-initial-setup-3.14.4-3.el7.x86_64
initial-setup-0.3.9.26-2.el7.x86_64


How reproducible:
=================

always


Steps to Reproduce:
===================

1. Manually bring up initial-setup (/bin/initial-setup)
2. click the Help button on any stage of the initial-setup process


Actual results:
===============

There is no help available in the new dialog that comes up


Expected results:
=================

There should be some kind of help information available for users related to the screen they are on (ie it should be context sensitive information, based on which frame they are on when they click the Help button)


Additional info:
Comment 1 Sean Toner 2015-07-28 16:51:06 EDT
Created attachment 1057145 [details]
Shows help dialog with no help info
Comment 6 Martin Kolman 2015-08-28 09:44:14 EDT
The missing help in Initial setup is caused by the InitialSetupHub-common.xml file missing from the help content (only InitialSetupHub.xml file is present). Reassigning to anaconda-user-help so that a help content update that fixes this can be made.
Comment 12 Jakub Vavra 2015-10-23 03:29:06 EDT
Removing FailedQA as it was verified.
Comment 13 errata-xmlrpc 2015-11-19 06:41:51 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2352.html

Note You need to log in before you can comment on or make changes to this bug.