Bug 1247804 - RHEL OSP Branded login page, credentials boxes don't disappear when selecting WebSSO login
RHEL OSP Branded login page, credentials boxes don't disappear when selecting...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: z2
: 7.0 (Kilo)
Assigned To: Matthias Runge
Prasanth Anbalagan
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-28 19:35 EDT by Jamie Lennox
Modified: 2015-10-25 21:12 EDT (History)
7 users (show)

See Also:
Fixed In Version: python-django-horizon-2015.1.1-2.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-08 08:22:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Login page with all fields (60.09 KB, image/jpeg)
2015-09-25 09:38 EDT, Prasanth Anbalagan
no flags Details
Login page with openid connect (56.50 KB, image/jpeg)
2015-09-25 09:39 EDT, Prasanth Anbalagan
no flags Details
Login page with saml (57.13 KB, image/jpeg)
2015-09-25 09:39 EDT, Prasanth Anbalagan
no flags Details

  None (edit)
Description Jamie Lennox 2015-07-28 19:35:33 EDT
In the upstream horizon login page when you configure it to use WebSSO login the username and password text boxes associated with your keystone login credentials will disappear as they are not used for websso. 

In the RHEL OSP branded login page this doesn't happen so if i select to use a SAML provider i still see username and password boxes which is confusing as any values entered here will be ignored. 

Versions: 

openstack-dashboard-theme-2015.1.0-10.el7ost.noarch
openstack-dashboard-2015.1.0-10.el7ost.noarch
python-django-horizon-2015.1.0-10.el7ost.noarch
Comment 3 Matthias Runge 2015-09-03 08:08:24 EDT
This happens only with our UI.
Comment 7 Matthias Runge 2015-09-25 02:44:19 EDT
How to test:

In /etc/openstack-dashboard/local_settings set
WEBSSO_ENABLED = True
WEBSSO_CHOICES = (
  ("credentials", _("Keystone Credentials")),
  ("oidc", _("OpenID Connect")),
  ("saml2", _("Security Assertion Markup Language"))
)

WEBSSO_INITIAL_CHOICE = "credentials"

And you need to set 
OPENSTACK_API_VERSIONS = {
#    "data-processing": 1.1,
    "identity": 3,
#    "volume": 2,
}

=> (identity, use version 3)
and restart httpd

At the login page, you should be able to choose between login methods. When selecting anything else other than Keystone Credentials, Username and password field should be hidden.
Comment 8 Prasanth Anbalagan 2015-09-25 09:38 EDT
Created attachment 1077105 [details]
Login page with all fields
Comment 9 Prasanth Anbalagan 2015-09-25 09:39 EDT
Created attachment 1077106 [details]
Login page with openid connect
Comment 10 Prasanth Anbalagan 2015-09-25 09:39 EDT
Created attachment 1077107 [details]
Login page with saml
Comment 11 Prasanth Anbalagan 2015-09-25 09:42:23 EDT
Upon making the above configuration, the login screen presented three options for
authentication - 'Keystone Credentials', 'OpenID Connect' and 'Security Assertion Markup Language' (SAML). Verified that with OpenID and SAML options selected, username and password fields disappeared.

Note: Please see attachments (.jpgs) for screenshots of the login screen.
Comment 13 errata-xmlrpc 2015-10-08 08:22:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1874

Note You need to log in before you can comment on or make changes to this bug.