Bug 1247825 - mono-nunit should not be packaged; nunit is newer
mono-nunit should not be packaged; nunit is newer
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mono (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-28 22:30 EDT by Hin-Tak Leung
Modified: 2015-08-10 06:09 EDT (History)
6 users (show)

See Also:
Fixed In Version: mono-4.0.2-6.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-10 05:55:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hin-Tak Leung 2015-07-28 22:30:56 EDT
Description of problem:
the mono 4.0.2.5 src rpm get built into a whole lot
of things, two of which are mono-nunit and mono-nunit-devel , which seems to be
nunit 2.4.8 . nunit 2.6.x is available as a separate package.

Version-Release number of selected component (if applicable):
mono-nunit-4.0.2-5.fc23.x86_64
nunit-2.6.4-8.fc23.x86_64

How reproducible:
Always


Steps to Reproduce:
1. install mono-nunit and try rpmbuild --rebuild monodevelop-5.9.4-2.fc23.src.rpm
2.
3.

Actual results:
fails

Expected results:
success

Additional info:
See discussion leading up to:
https://bugzilla.xamarin.com/show_bug.cgi?id=23696#c24

basically the private copy of nunit shipped with mono is a bit old and should not be packaged; more up-to-date version of nunit is available separately and monodevelop depends on that; packaging the private and old version of nunit and have it installed, confuses the build process.
Comment 1 Timotheus Pokorra 2015-08-04 10:48:34 EDT
Building monodevelop works if you uninstall mono-nunit first and install nunit instead.

I agree this should be cleaned up.

I wonder what the right steps are:
* change mono package to not build mono-nunit and mono-nunit-devel
* change nunit/nunit-devel package to obsolete mono-nunit/mono-nunit-devel

the following packages should be updated to require nunit/nunit-devel:

repoquery --repoid=rawhide-source --archlist=src --whatrequires mono-nunit-devel

gnome-do-0:0.95.3-2.fc23.src
hyena-0:0.5-11.fc23.src
libappindicator-0:12.10.0-10.fc23.src
mono-debugger-0:2.10-11.fc23.src
mono-tools-0:3.10-3.fc23.src
xsp-0:3.8-2.fc23.src

repoquery --repoid=rawhide-source --archlist=src --whatrequires mono-nunit

gdata-sharp-0:1.4.0.2-16.fc23.src
mono-tools-0:3.10-3.fc23.src
Comment 2 Fedora Update System 2015-08-04 12:32:11 EDT
nunit-2.6.4-9.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/nunit-2.6.4-9.fc23
Comment 3 Fedora Update System 2015-08-04 13:26:37 EDT
mono-4.0.2-6.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/mono-4.0.2-6.fc23
Comment 4 Fedora Update System 2015-08-04 20:11:49 EDT
Package mono-4.0.2-6.fc23:
* should fix your issue,
* was pushed to the Fedora 23 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mono-4.0.2-6.fc23'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-12732/mono-4.0.2-6.fc23
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2015-08-10 05:55:57 EDT
nunit-2.6.4-9.fc23 has been pushed to the Fedora 23 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2015-08-10 06:09:39 EDT
mono-4.0.2-6.fc23 has been pushed to the Fedora 23 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.