Bug 124788 - (ACPI) System hang upon sound init
(ACPI) System hang upon sound init
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-29 22:24 EDT by Drew DeNardo
Modified: 2015-01-04 17:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 01:05:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Drew DeNardo 2004-05-29 22:24:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
The first time anything tries to access my sound card the system hangs
hard (power off/on required).  Everything worked fine in Fedora Core
1.  This is a fresh install of Fedora Core 2.

Examples -- after install, start KDE session and it hangs while KDE is
initalizing devices (the progress bar is stuck at 42%).  If I log into
gnome (which I am guessing doesn't touch the sound card during its
startup) and run the sound card detection GUI widget it also hangs
hard if I press the "play a test sound" button.

Version-Release number of selected component (if applicable):
Linux rand 2.6.5-1.358 #1 Sat May 8 09:04:50 EDT 2004 i686 athlon i386
GNU/Linux

How reproducible:
Always

Steps to Reproduce:
1. Log into KDE session
2. System hangs hard when progress bar reaches 42%    

Actual Results:  System hang

Expected Results:  Desktop starts up and your system is available for use

Additional info:

I have a DFI AD77 Pro with a on-board sound (AC97 provided by the VIA
VT8235CD chipset).

I have removed the audio entry from /etc/sysconfig/hwconf and removed
the audio lines from /etc/modprobe.conf.  This is the only way I know
of to make this machine stable until this problem is fixed.

Output from lspci:
[root@rand root]# lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP]
Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8235 PCI Bridge
00:09.0 FireWire (IEEE 1394): Texas Instruments TSB12LV26 IEEE-1394
Controller (Link)
00:0b.0 Ethernet controller: Linksys NC100 Network Everywhere Fast
Ethernet 10/100 (rev 11)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc.
VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400 AGP
(rev 04)

I did notice the following driver difference between how FC1 and FC2
recognized my audio:

/etc/sysconfig/hwconf entry from Fedora Core 1:
class: AUDIO
bus: PCI
detached: 0
driver: via82cxxx_audio
desc: "VIA Technologies|VT8233/A/8235 AC97 Audio Controller"
vendorId: 1106
deviceId: 3059
subVendorId: 15bd
subDeviceId: 1001
pciType: 1
pcibus:  0
pcidev: 11
pcifn:  5

/etc/sysconfig/hwconf entry from Fedora Core 2:
class: AUDIO
bus: PCI
detached: 0
driver: snd-via82xx
desc: "VIA Technologies|VT8233/A/8235/8237 AC97 Audio Controller"
vendorId: 1106
deviceId: 3059
subVendorId: 15bd
subDeviceId: 1001
pciType: 1
pcidom:    0
pcibus:  0
pcidev: 11
pcifn:  5
Comment 1 Drew DeNardo 2004-06-18 00:11:29 EDT
I was not sufficiently patient -- the system does freeze for about 20
seconds but then continues.  This happens any time a sound is played.
Comment 2 Alan Cox 2004-06-18 18:42:11 EDT
Does this occur if you boot with acpi=off ?
Comment 3 Drew DeNardo 2004-06-18 21:44:18 EDT
I booted with apci=off to no avail.

Then I re-read your post and spelled the option right.

Booting with acpi=off did the trick!

Thanks a lot for the tip!  If there is anything else you would like me
to try so this can be made to work without a boot param I'm glad to be
the guinea pig!
Comment 4 Alan Cox 2004-06-18 22:01:23 EDT
Firstly confirm it occurs with the errata kernel too please
Comment 5 Drew DeNardo 2004-06-19 00:38:08 EDT
I had updated my kernel since my first post.  Looking in my /boot

-rw-r--r--  1 root root 1199031 May  8 09:21 vmlinuz-2.6.5-1.358
-rw-r--r--  1 root root 1203750 Jun 10 09:53 vmlinuz-2.6.6-1.427
-rw-r--r--  1 root root 1203768 Jun 14 09:23 vmlinuz-2.6.6-1.435

I've been running 2.6.6-1.435 since the 14th.

I'm not sure if that kernel is what you mean by the "errata kernel" --
I'll search the fedora mirrors & FAQs to see if I can find a reference
to such a thing.
Comment 6 Drew DeNardo 2004-06-19 00:45:50 EDT
.. and in case it was not clear all three of the above Kernels
exhibited the failure using the default boot params added to grub by a
RPM install of the kernel(s).  Adding the "acpi=off" flag when booting
into 2.6.6-1.435 cleared it up.  I've not tried adding the "acpi=off"
flag to the older kernels, would be glad to do so if that would be
helpful.
Comment 7 Alan Cox 2004-06-19 06:52:40 EDT
435 is the errata kernel sorry.

Thanks for confirming this is another ACPI problem - no need I think
to check the older kernels.
Comment 8 Dave Jones 2005-04-16 01:05:28 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.