Bug 1247883 - Ungrouping the last resource from a cloned group produces an invalid CIB
Ungrouping the last resource from a cloned group produces an invalid CIB
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pcs (Show other bugs)
6.7
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Tomas Jelinek
cluster-qe@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-29 03:27 EDT by Tomas Jelinek
Modified: 2016-05-10 15:28 EDT (History)
4 users (show)

See Also:
Fixed In Version: pcs-0.9.145-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: User moves the last resource from a cloned or mastered group to another group. Consequence: pcs produces an invalid CIB, exits with an error and dumps the CIB to a terminal. Fix: After moving the resource to the new group, remove the empty clone / master from the CIB. Result: Resource is successfully moved to the new group.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 15:28:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed fix (5.16 KB, patch)
2015-09-08 09:40 EDT, Tomas Jelinek
no flags Details | Diff

  None (edit)
Description Tomas Jelinek 2015-07-29 03:27:00 EDT
Description of problem:
Ungrouping the last resource from a cloned group produces an invalid CIB


Version-Release number of selected component (if applicable):
0.9.142


How reproducible:
easily


Steps to Reproduce:
1. pcs resource create d1 Dummy --group gr1
2. pcs resource create d2 Dummy --group gr2
3. pcs resource clone gr2
4. pcs resource group add gr1 d2


Actual results:
Error: Unable to update cib
Call cib_replace failed (-203): Update does not conform to the configured schema

The resource has been moved to the group, but the clone was not removed from the CIB:
<clone id="gr2-clone">
  <meta_attributes id="gr2-clone-meta"/>
</clone>

Expected results:
Resource moved to the new group.
Comment 1 Tomas Jelinek 2015-09-08 09:40:43 EDT
Created attachment 1071363 [details]
proposed fix
Comment 2 Tomas Jelinek 2015-11-04 06:58:51 EST
Before Fix:
[root@rh67-node1 ~]# rpm -q pcs
pcs-0.9.139-9.el6_7.1.x86_64
[root@rh67-node1:~]# pcs resource create d1 Dummy --group gr1
[root@rh67-node1:~]# pcs resource create d2 Dummy --group gr2
[root@rh67-node1:~]# pcs resource clone gr2
[root@rh67-node1:~]# pcs resource group add gr1 d2
Error: Unable to update cib
Call cib_replace failed (-203): Update does not conform to the configured schema
{snip}



After Fix:
[root@rh67-node1:~]# rpm -q pcs
pcs-0.9.145-1.el6.x86_64
[root@rh67-node1:~]# pcs resource create d1 Dummy --group gr1
[root@rh67-node1:~]# pcs resource create d2 Dummy --group gr2
[root@rh67-node1:~]# pcs resource clone gr2
[root@rh67-node1:~]# pcs resource group add gr1 d2
[root@rh67-node1:~]# pcs resource
 Resource Group: gr1
     d1 (ocf::heartbeat:Dummy): Started rh67-node1
     d2 (ocf::heartbeat:Dummy): Started rh67-node1
Comment 6 errata-xmlrpc 2016-05-10 15:28:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0739.html

Note You need to log in before you can comment on or make changes to this bug.