Bug 1247896 - [ko_KR][zh_CN][Admin/User Portal] The localized character of month "월 or 月" should be removed from this string for the Time in Events or any.
[ko_KR][zh_CN][Admin/User Portal] The localized character of month "월 or 月" s...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.5.4
x86_64 Linux
high Severity high
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Alexander Wels
Yuko Katabami
: i18n, Translation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-29 04:01 EDT by Lijun Li
Modified: 2016-04-19 21:34 EDT (History)
10 users (show)

See Also:
Fixed In Version: 3.6.0-15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 21:34:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The localized character of month "월 or 月" should be removed from this string for the Time in Events (11.73 KB, image/png)
2015-07-29 04:02 EDT, Lijun Li
no flags Details
korean_predefined_medium_date_time (28.56 KB, image/png)
2015-08-03 09:43 EDT, Alexander Wels
no flags Details
chinese_predifened_date_time (23.34 KB, image/png)
2015-08-03 09:44 EDT, Alexander Wels
no flags Details
japanese_predefined_short_date_time (23.23 KB, image/png)
2015-08-04 10:28 EDT, Alexander Wels
no flags Details
Event Tab in ko-KR (202.32 KB, image/png)
2015-09-28 22:19 EDT, Yuko Katabami
no flags Details
Event Tab in zh-CN (207.73 KB, image/png)
2015-09-28 22:19 EDT, Yuko Katabami
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 42875 None None None Never
oVirt gerrit 44249 None None None Never
oVirt gerrit 45108 None None None Never

  None (edit)
Description Lijun Li 2015-07-29 04:01:15 EDT
Description of problem:
The localized character of month "월 or 月" should be removed from this string for the Time in Events.

Version-Release number of selected component (if applicable):
3.5.4-1.2.el6ev

How reproducible:
100%

Steps to Reproduce:
1. Login Admin/User portal.
2. Click Events tab.
3. Check the Time format.

Actual results:
Refer to bug 870352

Expected results:
The localized character of month "월 or 月" should be removed from this string for the Time in Events.
OR
Update it to "2015년-7월-16일 11:11"

Additional info:
Please see the attached screenshot.
Comment 1 Lijun Li 2015-07-29 04:02:24 EDT
Created attachment 1057228 [details]
The localized character of month "월 or 月" should be removed from this string for the Time in Events
Comment 2 Einav Cohen 2015-07-30 17:17:45 EDT
Greg has already fixed that as part of his patch https://gerrit.ovirt.org/#/c/42875/. 

This would be further optimized by Alexander in the context of bug 1247776.
Comment 3 Einav Cohen 2015-07-31 09:23:43 EDT
only now realized that https://gerrit.ovirt.org/#/c/42875/ hasn't really changed any re: formats per locale - it preserved the previous behaviour - one format for Japanese, another format for non-Japanese; and this BZ is actually about Chinese and Korean. 

Assigning to Alexander that is already working on using pre-defined formats that should work well for *all* locales. 

so this one is a "duplicate" of bug 1247776 (since one is oVirt and the other is RHEV - not actually closing on duplicate).
Comment 4 Alexander Wels 2015-08-03 09:43:58 EDT
Created attachment 1058772 [details]
korean_predefined_medium_date_time

Korean dates, which are predefined part of GWT.
Comment 5 Alexander Wels 2015-08-03 09:44:48 EDT
Created attachment 1058773 [details]
chinese_predifened_date_time

Chinese predefined date/time
Comment 6 Alexander Wels 2015-08-03 09:46:29 EDT
Hi, I just attached screen shots of the 'medium' predefined date formats for both Korean and Chinese. These are built into the language so I am assuming the format is correct, but I would like you to double check that this format is acceptable.
Comment 7 Lijun Li 2015-08-03 22:54:59 EDT
(In reply to Alexander Wels from comment #6)
> Hi, I just attached screen shots of the 'medium' predefined date formats for
> both Korean and Chinese. These are built into the language so I am assuming
> the format is correct, but I would like you to double check that this format
> is acceptable.

OK for Chinese.

@ Eun Ju Kim, could you double check if the time format for Korean is acceptable?
Comment 8 Eunju, Kim 2015-08-03 23:44:41 EDT
Hi, I've checked the screen shot.
It appear 15.7.31. Is it possible to present it in full year like 2015.7.31 to make it more clear? 

Thank you.
Comment 9 Lijun Li 2015-08-04 00:10:34 EDT
+1 .
@ Alexander, could you make the year full long as yyyy for all locales, same as Japanese.
Comment 10 Alexander Wels 2015-08-04 10:27:10 EDT
Actually with the proposed change the Japanese locale will also be yy instead of yyyy. The problem is to properly support all locales (current and future ones). I have to use the predefined formats. When I use those, the system will automatically alter the pattern used to format the dates according to the selected locale.

None of the available pre-defined formats have the medium date (full year) and a short time (only hours/minutes). So in short it is not possible to have the full year and just hours and minutes. I am attaching the Japanese version of this as well so you can compare.
Comment 11 Alexander Wels 2015-08-04 10:28:47 EDT
Created attachment 1059115 [details]
japanese_predefined_short_date_time
Comment 12 Alexander Wels 2015-08-04 10:29:52 EDT
Hmm looking at the Japanese version of this, it does show the full year. Not sure why.
Comment 13 Einav Cohen 2015-08-30 10:00:47 EDT
associating with patches that fixed bug 1247776 (these patches are not available in the latest 3.6 build yet, AFAIK - they should be available in the upcoming 3.6 build).
Comment 14 Eunju, Kim 2015-09-28 19:41:34 EDT
Checked Date format for Korean in RHEV 3.6 QA.
It looks good. thank you.

Eun-Ju
Comment 15 Yuko Katabami 2015-09-28 20:09:23 EDT
Thank you Eun Ju.
Moving the status to VERIFIED.
Comment 16 Yuko Katabami 2015-09-28 22:19 EDT
Created attachment 1078124 [details]
Event Tab in ko-KR
Comment 17 Yuko Katabami 2015-09-28 22:19 EDT
Created attachment 1078125 [details]
Event Tab in zh-CN
Comment 18 Yuko Katabami 2015-09-29 00:11:26 EDT
Tony (tfu@redhat.com) has verified zh-CN.

Note You need to log in before you can comment on or make changes to this bug.