Bug 124792 - svnadmin create fails with Berkeley DB error
svnadmin create fails with Berkeley DB error
Status: CLOSED DUPLICATE of bug 91933
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-30 02:36 EDT by Andrew Pam
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Pam 2004-05-30 02:36:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031016 Galeon/1.3.10

Description of problem:
Any attempt to run "svnadmin create xxx" to create a repository xxx
fails with the following error message:

svn: Berkeley DB error
svn: Berkeley DB error while creating environment for filesystem xxx/db:
Invalid argument

This error occurs whether running as a normal user or as root.

The version of db4 installed is db4-4.1.25-14.

Version-Release number of selected component (if applicable):
subversion-0.32.1-2

How reproducible:
Always

Steps to Reproduce:
1. Run "svnadmin create xxx"
    

Actual Results:  svn: Berkeley DB error
svn: Berkeley DB error while creating environment for filesystem xxx/db:
Invalid argument

Expected Results:  svn repository successfully created in the
directory xxx.

Additional info:
Comment 1 Joe Orton 2004-05-30 16:59:03 EDT

*** This bug has been marked as a duplicate of 91933 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.