Bug 1247928 - virt-who refresh interval is 15min although setting interval 1 hour
virt-who refresh interval is 15min although setting interval 1 hour
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-who (Show other bugs)
7.2
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Radek Novacek
Eko
:
Depends On: 1230041
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-29 05:18 EDT by Liushihui
Modified: 2016-11-30 19:36 EST (History)
7 users (show)

See Also:
Fixed In Version: virt-who-0.17-1.el7
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of: 1230041
Environment:
Last Closed: 2016-11-04 01:05:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Radek Novacek 2015-07-30 07:29:33 EDT
There is planned change in virt-who that it will only send host/guest association when it's changed (mostly to reduce the load it generates to the candlepin server). Since this issue is not critical, I suggest we wait for this feature as it will also address this bug. Moving to 7.3.
Comment 3 Radek Novacek 2016-04-21 07:21:45 EDT
Upstream virt-who (that will get to 7.3 by rebase) is now sending host/guest association only when it changes.
Comment 4 Radek Novacek 2016-05-17 09:02:48 EDT
Fixed in virt-who-0.17-1.el7.
Comment 6 Liushihui 2016-06-02 03:08:33 EDT
Verified it on virt-who-0.17-2.el7.noarch since virt-who can refresh host/guest association every 1 hour. Therefore, verify it.

Verified version:
subscription-manager-1.17.6-1.el7.x86_64
python-rhsm-1.17.2-1.el7.x86_64
python-rhsm-1.17.2-1.el7.x86_64

Verified process:
1. register system to satellite6.2
2. Configure virt-who run at esx mode and refresh interval is 3600s
[root@dell-per920-02 ~]# cat /etc/sysconfig/virt-who  | grep -v ^# | grep -v ^$
VIRTWHO_DEBUG=1
VIRTWHO_INTERVAL=3600

[root@dell-per920-02 ~]# cat /etc/virt-who.d/virt 
[test-esx1]
type=esx
server=10.73.2.95
username=Administrator@vsphere.local
password=Welcome1!
owner=ACME_Corporation
env=Library
3. Restart virt-who service and check virt-who's log after 1h.
2016-06-02 01:55:20,184 [virtwho.test-esx1 DEBUG] Esx-1(86984):MainThread @virt.py:enqueue:357 - Report for config "test-esx1" gathered, putting to queue for sending
2016-06-02 01:55:20,204 [virtwho.main DEBUG] MainProcess(86977):MainThread @subscriptionmanager.py:_connect:123 - Authenticating with certificate: /etc/pki/consumer/cert.pem
2016-06-02 01:55:22,013 [virtwho.main DEBUG] MainProcess(86977):MainThread @subscriptionmanager.py:hypervisorCheckIn:171 - Checking if server has capability 'hypervisor_async'
2016-06-02 01:55:23,817 [virtwho.main DEBUG] MainProcess(86977):MainThread @subscriptionmanager.py:hypervisorCheckIn:183 - Server does not have 'hypervisors_async' capability
2016-06-02 01:55:23,818 [virtwho.main INFO] MainProcess(86977):MainThread @subscriptionmanager.py:hypervisorCheckIn:194 - Sending update in hosts-to-guests mapping for config "test-esx1": 2 hypervisors and 1 guests found
2016-06-02 01:55:23,818 [virtwho.main DEBUG] MainProcess(86977):MainThread @subscriptionmanager.py:hypervisorCheckIn:195 - Host-to-guest mapping: {
    "3e504d56-3982-037b-f3e6-669289892fa1": [
        {
            "guestId": "4206405a-4133-bd0c-f8a5-9c7bc1355837", 
            "state": 1, 
            "attributes": {
                "active": 1, 
                "virtWhoType": "esx"
            }
        }
    ], 
    "60554d56-20cb-f25e-7ab9-33e7e330dc15": []
}
2016-06-02 01:55:25,917 [virtwho.main DEBUG] MainProcess(86977):MainThread @executor.py:send_report:101 - Report for config "test-esx1" sent

===============After 1h, virt-who check mapping info================
2016-06-02 02:55:20,428 [virtwho.test-esx1 DEBUG] Esx-1(86984):MainThread @virt.py:enqueue:357 - Report for config "test-esx1" gathered, putting to queue for sending
2016-06-02 02:55:20,434 [virtwho.main INFO] MainProcess(86977):MainThread @executor.py:run:250 - Report for config "test-esx1" hasn't changed, not sending

Result:
virt-who can refresh host/guest association every 1 hour.
Comment 9 errata-xmlrpc 2016-11-04 01:05:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2387.html

Note You need to log in before you can comment on or make changes to this bug.