Bug 124793 - Anaconda crashes on hard disk install with raid
Anaconda crashes on hard disk install with raid
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-30 04:00 EDT by Phil Anderson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-22 12:09:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda Crash Dump (76.78 KB, text/plain)
2004-05-30 04:01 EDT, Phil Anderson
no flags Details

  None (edit)
Description Phil Anderson 2004-05-30 04:00:30 EDT
Description of problem:
I tried to upgrade to FC2 using the ISO's on my raid-1 partitino. 
When I selected to do a Hard Disk install, anacond presented me with
the raw devices (not md0, md1, etc).  I one of the two raid-1
partitions (hda7) and it continued on a little bit, and then anaconda
crashed out.  I tried again, but it didnt' work.  In the end i had to
install off CDs.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install FC1
2. Copy FC2 ISO's to a raid-1 device
3. Try to do a hard disk install with the ISOS
    

Actual Results:  Crash and burn

Expected Results:  Either this should be supported, or anaconda should
tell you that you aren't allowed to install off a device which makes
up a raid-1 md.

Additional info:
Comment 1 Phil Anderson 2004-05-30 04:01:20 EDT
Created attachment 100701 [details]
Anaconda Crash Dump
Comment 2 Jeremy Katz 2004-06-01 16:14:23 EDT
This isn't supported.  It's a bit tricky to make clear, though, as we
don't have the RAID modules available and so can't say definitively
that a disk is part of a working RAID set :/
Comment 3 Phil Anderson 2004-06-01 18:07:55 EDT
It is possible to only show partitions which are supported by using
fdisk or some system call which returns the same?

/sbin/fdisk -l /dev/hda
 
Disk /dev/hda: 40.0 GB, 40000000000 bytes
255 heads, 63 sectors/track, 4863 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
 
   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1           5       40131    6  FAT16
/dev/hda2               6          18      104422+  fd  Linux raid
autodetect
/dev/hda3              19         655     5116702+  fd  Linux raid
autodetect
/dev/hda4             656        4863    33800760    f  W95 Ext'd (LBA)
/dev/hda5             656        1292     5116671   fd  Linux raid
autodetect
/dev/hda6            1293        1423     1052226   82  Linux swap
/dev/hda7            1424        4863    27631768+  fd  Linux raid
autodetect
Comment 4 Jeremy Katz 2004-06-01 18:42:21 EDT
There's no system call to give this information, and even if there
were, it's completely informational and not at all mandatory. 
Partition table ids are a fairly arbitrary concept that don't exist in
a lot of partition table formats.
Comment 5 Phil Anderson 2004-06-01 19:44:51 EDT
Well, if it is too hard to hide the raid partitions from the list,
maybe just put a few lines of error checking in to avoid crashing out?
Comment 6 Chris Lumens 2007-03-22 12:09:50 EDT
It doesn't look like we can add specific error checking to catch that you've
specified a RAID partition in the loader.  However, we can certainly catch the
error when we try to mount the partition later on.  This will be fixed in the
next build of anaconda.

Note You need to log in before you can comment on or make changes to this bug.