Bug 1247946 - Enable feature to update all packages for a host collection to patch all hosts at once
Enable feature to update all packages for a host collection to patch all host...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hosts (Show other bugs)
6.0.8
Unspecified Unspecified
medium Severity medium (vote)
: GA
: --
Assigned To: John Mitsch
jcallaha
http://projects.theforeman.org/issues...
: Patch, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-29 06:15 EDT by Komal
Modified: 2016-07-27 07:35 EDT (History)
7 users (show)

See Also:
Fixed In Version: rubygem-katello-3.0.0.31-1,rubygem-katello-3.0.0.31-1,rubygem-katello-3.0.0.31-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:35:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14940 None None None 2016-05-05 15:03 EDT

  None (edit)
Description Komal 2015-07-29 06:15:07 EDT
Description of problem:

How to patch all hosts through Satellite 6 in host collection.

We can patch individual packages for a host collection, but there is no way to update all packages for a host collection. Also, there should be a way to check (logs of) what was updated when.

Version-Release number of selected component (if applicable):
Satellite 6

How reproducible:
Always

Steps to Reproduce:
1. on satellite 6 web UI : Go to Hosts -> Host collection
2. On the host collection created -> Collection Actions
3. Package Installation, removal and Update -> we need to search for particular package or group and perform the action
4. There is no way to patch hosts with all updates available 

Actual results:
No way to patch all hosts at once for multiple packages.
The similar facility is available in satellite 5.x using SSM.

Expected results:
All hosts in a host collection should be able to be updated for multiple updates.

There is existing bugzilla for adding feature for tracking tasks for host collection. https://bugzilla.redhat.com/show_bug.cgi?id=1192889

Additional info:
Comment 3 John Call 2015-08-28 12:22:51 EDT
(In reply to Komal from comment #0)
> How to patch all hosts through Satellite 6 in host collection.
>
> Steps to Reproduce:
> 1. on satellite 6 web UI : Go to Hosts -> Host collection

...

This bug is specific to the GUI -- I'm curious if there is a workaround available using the Hammer CLI tooling.

Thanks,
John
Comment 4 Komal 2015-09-15 07:20:26 EDT
Hello,

Do we have any other workaround to achieve the mentioned requirement using hammer?

Is there any timeline when the feature can be fixed for satellite 6.x web UI ?

Regards,
Komal
Comment 5 John Call 2015-09-15 09:20:45 EDT
(In reply to Komal from comment #4)
> Hello,
> 
> Do we have any other workaround to achieve the mentioned requirement using
> hammer?

...

Komal,

do these [1] instructions provide any relief?

[1] - https://access.redhat.com/articles/1595873
Comment 7 John Mitsch 2016-05-05 14:56:43 EDT
Created redmine issue http://projects.theforeman.org/issues/14940 from this bug
Comment 8 Bryan Kearney 2016-05-12 12:08:37 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/14940 has been closed
Comment 9 jcallaha 2016-06-15 15:23:20 EDT
Verified in Satellite 6.2 Beta Snap 15.2

All package actions are now available for host collections in the ui.
Comment 11 Bryan Kearney 2016-07-27 07:35:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.