Bug 1247970 - huge mem leak in posix xattrop
huge mem leak in posix xattrop
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.6.4
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vijaikumar Mallikarjuna
:
Depends On: 1243890
Blocks: glusterfs-3.6.5
  Show dependency treegraph
 
Reported: 2015-07-29 07:08 EDT by Vijaikumar Mallikarjuna
Modified: 2016-05-11 18:48 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.6.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1243890
Environment:
Last Closed: 2015-08-27 09:06:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2015-07-29 07:10:39 EDT
REVIEW: http://review.gluster.org/11794 (posix: fix mem-leak in posix xattrop) posted (#1) for review on release-3.6 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Anand Avati 2015-08-18 06:42:28 EDT
REVIEW: http://review.gluster.org/11794 (posix: fix mem-leak in posix xattrop) posted (#3) for review on release-3.6 by Raghavendra Bhat (raghavendra@redhat.com)
Comment 3 Anand Avati 2015-08-20 03:26:53 EDT
COMMIT: http://review.gluster.org/11794 committed in release-3.6 by Raghavendra Bhat (raghavendra@redhat.com) 
------
commit 620403b48a021593883f39dec3a1d6bc16c53517
Author: vmallika <vmallika@redhat.com>
Date:   Wed Jul 29 16:37:13 2015 +0530

    posix: fix mem-leak in posix xattrop
    
    This is a backport of http://review.gluster.org/#/c/11700/
    
    > Change-Id: I1dd70f74a98c5875eb316f3c3e560047f128685b
    > BUG: 1243890
    > Signed-off-by: vmallika <vmallika@redhat.com>
    > Reviewed-on: http://review.gluster.org/11700
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    
    Change-Id: Ia192342f01330f8b2c7a520a7cc749471af7d85f
    BUG: 1247970
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/11794
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>
Comment 4 Raghavendra Bhat 2015-08-27 09:06:38 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.6.5, please open a new bug report.

glusterfs-3.6.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-devel/2015-August/046570.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.