Bug 124799 - Graphics card ATI Radeon 9800SE not recognised by Fedora Core 2 - defaulting to VESA driver during configuration
Graphics card ATI Radeon 9800SE not recognised by Fedora Core 2 - defaulting ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-30 06:44 EDT by Morten Jensen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 17:23:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Morten Jensen 2004-05-30 06:44:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Just performed a Workstation installation of Fedora Core 2 and updated
it with the latest packages using up2date -u.

However, my Sapphire (ATI) Radeon 9800SE graphics card is not
recognised and X is therefore defaulting to the generic VESA driver.

I've tried to manually choose the graphics card using the GNOME
Display settings and setting it to the ATI Radeon 9800 card option.
However, when the X server is restarted it's defaulting back to the
VESA driver.

How may I resolve this problem?

Thanks.

Best regards,

Morten Jensen

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Fedora Core 2 with an ATI Radeon 9800SE graphics card
    

Actual Results:  Defaulting to VESA driver. Accelerated 2D speed and
3D won't be availabile for games etc.


Expected Results:  'Native' support for graphics card.

Additional info:

N/A
Comment 1 Morten Jensen 2004-05-30 11:04:59 EDT
Woops, checked the Xorg.log and found that it correctly identified the
graphics card after all, while the Display application always seems to
default to VESA - possibly because the ATI Radeon 9800 SE is not in
its list of recognised graphics cards?
Comment 2 Mike A. Harris 2004-07-18 09:28:45 EDT
Please attach the output of the command:  lspci -vn

Once we've got that, I'll update the hardware database with a
mapping for the Radeon 9800 SE.

Thanks for the report.
Comment 3 Mike A. Harris 2004-08-30 17:23:55 EDT
Never got your PCI ID, but I've updated many ATI devices in
rawhide hwdata.  Closing as fixed in rawhide.  If your particular
card doesn't autodetect in FC3 test2 or later, add the
information requested in comment #2 above and reopen for review.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.