This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1247996 - sepolicy gui does not start because of traceback
sepolicy gui does not start because of traceback
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pygobject3 (Show other bugs)
7.2
All Linux
medium Severity high
: rc
: ---
Assigned To: Matthew Barnes
Desktop QE
: Regression
Depends On:
Blocks: 1246123 1246125 1259988 1222637
  Show dependency treegraph
 
Reported: 2015-07-29 08:16 EDT by Milos Malik
Modified: 2015-11-19 02:33 EST (History)
12 users (show)

See Also:
Fixed In Version: pygobject3-3.14.0-3.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 02:33:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2015-07-29 08:16:10 EDT
Description of problem:
 * sepolicy gui is not able to start on RHEL-7.2, but it was able to start on RHEL-7.1

Version-Release number of selected component (if applicable):
policycoreutils-python-2.2.5-18.el7.x86_64
policycoreutils-sandbox-2.2.5-18.el7.x86_64
policycoreutils-restorecond-2.2.5-18.el7.x86_64
policycoreutils-2.2.5-18.el7.x86_64
policycoreutils-gui-2.2.5-18.el7.x86_64
policycoreutils-devel-2.2.5-18.el7.x86_64
policycoreutils-newrole-2.2.5-18.el7.x86_64

How reproducible:
always

Steps to Reproduce:
# sepolicy gui
Traceback (most recent call last):
  File "/usr/bin/sepolicy", line 644, in <module>
    args.func(args)
  File "/usr/bin/sepolicy", line 289, in gui_run
    import sepolicy.gui
  File "/usr/lib64/python2.7/site-packages/sepolicy/gui.py", line 32, in <module>
    from sepolicy.sedbus import SELinuxDBus
  File "/usr/lib64/python2.7/site-packages/sepolicy/sedbus.py", line 5, in <module>
    from slip.dbus import polkit
  File "/usr/lib/python2.7/site-packages/slip/dbus/__init__.py", line 6, in <module>
    import service
  File "/usr/lib/python2.7/site-packages/slip/dbus/service.py", line 28, in <module>
    from slip._wrappers import _gobject as GObject
  File "/usr/lib/python2.7/site-packages/slip/_wrappers/_gobject.py", line 47, in <module>
    setattr(_self, what, getattr(_mod, what))
  File "/usr/lib64/python2.7/site-packages/gi/__init__.py", line 62, in __getattr__
    raise AttributeError(_static_binding_error)
AttributeError: When using gi.repository you must not import static modules like "gobject". Please change all occurrences of "import gobject" to "from gi.repository import GObject". See: https://bugzilla.gnome.org/show_bug.cgi?id=709183
#

Expected results:
 * sepolicy gui starts successfully
Comment 4 Petr Lautrbach 2015-08-11 04:23:00 EDT
This seems to be caused by a rebase of pygobject3 to 3.14.0, bug #1222637 

I'll take a look if we can make a fix for policycoreutils, but there might be other problems with the incompatible pygobject3 rebase in other packages or third party software.
Comment 5 Petr Lautrbach 2015-08-14 10:18:09 EDT
I can't reproduce the reported problem but I've a problem with pygobject3 which could be related?

# python
Python 2.7.5 (default, Apr  9 2015, 11:03:32) 
[GCC 4.8.3 20140911 (Red Hat 4.8.3-9)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> from gi.repository import Gtk
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib64/python2.7/site-packages/gi/__init__.py", line 42, in <module>
    from . import _gi
ImportError: /usr/lib64/python2.7/site-packages/gi/_gi.so: undefined symbol: g_type_check_instance_is_fundamentally_a

# rpm -qf /usr/lib64/python2.7/site-packages/gi/_gi.so
pygobject3-base-3.14.0-2.el7.x86_64
Comment 6 Milos Malik 2015-08-14 12:08:45 EDT
# rpm -qa pyg\*
pygobject3-3.14.0-2.el7.x86_64
pygobject2-2.28.6-11.el7.x86_64
pygpgme-0.3-9.el7.x86_64
pygtk2-2.24.0-9.el7.x86_64
pygobject3-base-3.14.0-2.el7.x86_64
pygtk2-libglade-2.24.0-9.el7.x86_64
#
Comment 7 Matthew Barnes 2015-09-15 12:11:32 EDT
The quoted bug in the traceback [1] seems to me too aggressive for a stable enterprise update.  I think best back that change out for RHEL 7.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=709183
Comment 8 Matthew Barnes 2015-09-15 14:17:26 EDT
Patched pygobject3-3.14.0-3.el7
Comment 9 Milos Malik 2015-09-16 04:09:49 EDT
I can confirm that sepolicy gui starts successfully after updating pygobject3 packages to 3.14.0-3.el7 version.
Comment 10 errata-xmlrpc 2015-11-19 02:33:52 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2215.html

Note You need to log in before you can comment on or make changes to this bug.