Bug 1248000 - The json-c package needs to be removed from EPEL-6
The json-c package needs to be removed from EPEL-6
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: json-c (Show other bugs)
el6
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Christopher Meng
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-29 08:27 EDT by Akemi Yagi
Modified: 2017-04-27 06:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-27 06:38:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akemi Yagi 2015-07-29 08:27:18 EDT
Description of problem:
The json-c package exists in RHEL-6 and therefore must be removed from EPEL-6.

Version-Release number of selected component (if applicable):

RHEL 6: json-c-0.11-11.el6
EPEL 6: json-c-0.10-2.el6

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Christopher Meng 2015-07-29 08:30:28 EDT
Well...

I didn't receive any warnings or notes from RHEL team, seems that they just added it in the last year. But I obsoleted the 0.12 build on 0.12 in the last year as well.

I will retire it soon.
Comment 2 Akemi Yagi 2015-07-29 08:33:08 EDT
I believe it was added to RHEL last December or so.
Comment 3 Christopher Meng 2015-07-29 08:39:33 EDT
(In reply to Akemi Yagi from comment #2)
> I believe it was added to RHEL last December or so.

Tomas added this to RHEL6 in May 2014, and I didn't get any notifications.

http://pkgs.org/centos-6/centos-i386/json-c-0.11-11.el6.i686.rpm.html
Comment 4 Radek Bíba 2015-07-29 08:52:35 EDT
Officially, the package was shipped live in October, with RHEL-6.6.0: https://rhn.redhat.com/errata/RHEA-2014-1530.html

You may be interested in lists of new packages in RHEL Technical Notes:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/6.6_Technical_Notes/ch07.html
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/6.7_Technical_Notes/ch06.html
Comment 5 Christopher Meng 2015-07-29 09:02:18 EDT
(In reply to Radek Bíba from comment #4)
> Officially, the package was shipped live in October, with RHEL-6.6.0:
> https://rhn.redhat.com/errata/RHEA-2014-1530.html
> 
> You may be interested in lists of new packages in RHEL Technical Notes:
> 
> https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/
> html/6.6_Technical_Notes/ch07.html
> https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/
> html/6.7_Technical_Notes/ch06.html

Thank you for the sources provided. I often read the RHEL changelog in the past but I haven't done this since RHEL 6.4.
Comment 6 Björn 'besser82' Esser 2017-04-27 06:38:55 EDT
Package was orphaned…

Note You need to log in before you can comment on or make changes to this bug.