This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1248017 - [ovirt-node] admin tui session gets logged out all the time if using the serial console
[ovirt-node] admin tui session gets logged out all the time if using the seri...
Status: CLOSED NEXTRELEASE
Product: ovirt-node
Classification: oVirt
Component: General (Show other bugs)
---
Unspecified Unspecified
high Severity urgent (vote)
: ovirt-3.6.2
: ---
Assigned To: Anatoly Litovsky
bugs@ovirt.org
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-29 08:48 EDT by Jiri Belka
Modified: 2016-02-10 14:17 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-03 06:54:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
fdeutsch: ovirt‑3.6.z?
mgoldboi: planning_ack+
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Jiri Belka 2015-07-29 08:48:21 EDT
Description of problem:

super annoying - admin tui session gets logged out quite often. i tried to setup hostname of clean ovirt-node install and got logged out to console - _console_ here is serial console via SOL.

Jul 29 12:34:23 localhost login: DIALUP AT ttyS1 BY admin
Jul 29 12:34:23 localhost login: LOGIN ON ttyS1 BY admin
Jul 29 12:34:23 localhost sudo: admin : TTY=ttyS1 ; PWD=/home/admin ; USER=root ; COMMAND=/sbin/persist /etc/passwd /etc/shadow
Jul 29 12:34:23 localhost sudo: admin : TTY=ttyS1 ; PWD=/home/admin ; USER=root ; COMMAND=/bin/chage -l root
Jul 29 12:34:23 localhost sudo: admin : TTY=ttyS1 ; PWD=/home/admin ; USER=root ; COMMAND=/bin/chage -l admin
Jul 29 12:34:23 localhost sudo: admin : TTY=ttyS1 ; PWD=/home/admin ; USER=root ; COMMAND=/bin/dmesg -n 1
Jul 29 12:34:23 localhost sudo: admin : TTY=ttyS1 ; PWD=/home/admin ; USER=root ; COMMAND=/usr/bin/ovirt-node-setup
Jul 29 12:34:38 localhost login: pam_unix(login:session): session closed for user admin


Version-Release number of selected component (if applicable):
ovirt-node-3.3.0-0.999.master.el7.centos.noarch

How reproducible:
100%

Steps to Reproduce:
1. login to admin tui via serial consoel (SOL)
2. go to Network and try to change hostname (->, <end>, <backspace> to delete current content, start typing...
3.

Actual results:
admin is kickout and is on login

Expected results:
should work as expected

Additional info:
no idea what's going on...
Comment 1 Jiri Belka 2015-08-17 09:37:40 EDT
same happens with RHEV-H 6.6-20150603.0.el6ev
Comment 2 Fabian Deutsch 2015-09-07 11:02:43 EDT
I can not reproduce this with rhevh-7.1-20150827.1 and a serial console attached to a VM

Jiri, can you test if this bug also reproduces on a different host?
Comment 3 Jiri Belka 2015-10-13 06:34:08 EDT
Well, you told me you tried with virtual host. I just retried with Dell R210 via ipmitool and it again logged me out.

I also tried ssh to IBM Xseries's RSA card, and it was working fine.

If you do not have SOL accessible via ipmitool, ping me I can share my host with you.
Comment 4 Red Hat Bugzilla Rules Engine 2015-10-22 03:49:17 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 5 Red Hat Bugzilla Rules Engine 2015-10-22 09:09:34 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 6 Yaniv Lavi (Dary) 2015-10-29 08:23:40 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 7 Anatoly Litovsky 2015-11-02 04:13:21 EST
Jiri can you please set me up with a host that has thee problem?
Comment 8 Jiri Belka 2015-11-03 06:53:51 EST
fails - ovirt-node-iso-3.6-0.999.201507262016.el7.centos
success - rhev-hypervisor7-7.2-20151029.0
Comment 9 Fabian Deutsch 2015-11-03 06:54:47 EST
Thanks for teh update.

Closing this bug as of comment 8

Note You need to log in before you can comment on or make changes to this bug.