Bug 1248035 - VM migration: migration failed since vdsm failed to run VM on remove host
VM migration: migration failed since vdsm failed to run VM on remove host
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity urgent
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Francesco Romani
Israel Pinto
: AutomationBlocker
: 1248888 1249709 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-29 09:20 EDT by Israel Pinto
Modified: 2016-03-09 14:43 EST (History)
12 users (show)

See Also:
Fixed In Version: ovirt-3.6.0-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 14:43:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm and engine log (458.59 KB, application/x-bzip)
2015-07-29 09:20 EDT, Israel Pinto
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 44120 None None None Never

  None (edit)
Description Israel Pinto 2015-07-29 09:20:24 EDT
Created attachment 1057319 [details]
vdsm and engine log

Description of problem:
Migration failed since vdsm failed to run VM on remove host.

Version-Release number of selected component (if applicable):
3.6.0-4: oVirt Engine Version: 3.6.0-0.0.master.20150727175355.git0d51373.el6
VDSM:vdsm-4.17.0-1201.git7ba0684.el7

How reproducible:
All the time

Steps to Reproduce:
Migrate once VM

Actual results:
Migration failed

Expected results:
Migration success 

Additional info:
VDSM log:
Thread-228::DEBUG::2015-07-29 15:26:23,108::vm::393::virt.vm::(send_status_event) vmId=`4262b113-4d26-4336-9776-5e1766ed5acc`::Last status Up and evaluated status Migration Source
Thread-228::DEBUG::2015-07-29 15:26:23,108::__init__::206::jsonrpc.Notification::(emit) Sending event {"params": {"notify_time": 4300873380, "4262b113-4d26-4336-9776-5e1766ed5acc": {"status": "Migration Source"}}, "jsonrpc": "2.0", "method": "|virt|VM_status|4262b113-4d26-4336-9776-5e1766ed5acc"}
Thread-228::DEBUG::2015-07-29 15:26:23,108::stompreactor::305::yajsonrpc.StompServer::(send) Sending response
Thread-228::DEBUG::2015-07-29 15:26:23,109::__init__::534::jsonrpc.JsonRpcServer::(_serveRequest) Return 'VM.migrate' in bridge with True
Thread-228::DEBUG::2015-07-29 15:26:23,109::stompreactor::305::yajsonrpc.StompServer::(send) Sending response
Thread-229::ERROR::2015-07-29 15:26:23,120::migration::208::virt.vm::(_recover) vmId=`4262b113-4d26-4336-9776-5e1766ed5acc`::'str' object has no attribute 'subscribe'
Thread-229::ERROR::2015-07-29 15:26:23,120::migration::213::virt.vm::(_recover) vmId=`4262b113-4d26-4336-9776-5e1766ed5acc`::Failed to destroy remote VM
Traceback (most recent call last):
  File "/usr/share/vdsm/virt/migration.py", line 211, in _recover
    self._destServer.destroy(self._vm.id)
AttributeError: 'SourceThread' object has no attribute '_destServer'
Thread-229::ERROR::2015-07-29 15:26:23,120::migration::310::virt.vm::(run) vmId=`4262b113-4d26-4336-9776-5e1766ed5acc`::Failed to migrate
Traceback (most recent call last):
  File "/usr/share/vdsm/virt/migration.py", line 278, in run
    self._setupVdsConnection()
  File "/usr/share/vdsm/virt/migration.py", line 146, in _setupVdsConnection
    self._destServer = jsonrpcvdscli.connect(client, requestQueue)
  File "/usr/lib/python2.7/site-packages/vdsm/jsonrpcvdscli.py", line 119, in connect
    str(uuid4())
  File "/usr/lib/python2.7/site-packages/yajsonrpc/stompreactor.py", line 538, in StompRpcClient
    stomp_client.subscribe(response_queue, sub_id=str(uuid4())),
AttributeError: 'str' object has no attribute 'subscribe'
Comment 2 Francesco Romani 2015-07-29 10:16:42 EDT
let's recheck once https://gerrit.ovirt.org/#/c/44120/ is in the build
Comment 3 Omer Frenkel 2015-08-02 04:54:57 EDT
*** Bug 1248888 has been marked as a duplicate of this bug. ***
Comment 4 Omer Frenkel 2015-08-04 07:33:38 EDT
*** Bug 1249709 has been marked as a duplicate of this bug. ***
Comment 5 Israel Pinto 2015-08-11 08:24:02 EDT
Verify with version:3.6.0-5
3.6.0-0.0.master.20150804111407.git122a3a0.el6
VDSM: vdsm-4.17.0-1239.git6575e3f.el7.noarch
Check with Automation and manually
https://rhev-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/3.6-GE-compute/144/
Comment 8 errata-xmlrpc 2016-03-09 14:43:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0362.html

Note You need to log in before you can comment on or make changes to this bug.