Bug 1248051 - alloc: Fix lvextend failure when varying stripes.
alloc: Fix lvextend failure when varying stripes.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.8
Unspecified Linux
high Severity high
: rc
: ---
Assigned To: LVM and device-mapper development team
cluster-qe@redhat.com
: ZStream
Depends On: 1244257
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-29 09:59 EDT by Jaroslav Reznik
Modified: 2015-08-13 05:02 EDT (History)
12 users (show)

See Also:
Fixed In Version: lvm2-2.02.118-3.el6_7.2
Doc Type: Bug Fix
Doc Text:
When extending a logical volume (LV) where the amount of data stripes was previously lowered, the LV terminated unexpectedly with a segmentation fault due to an error in stripe position detection. With this update, the behavior of a number of functions related to stripe detection has been adjusted to prevent the bug, and the described crash no longer occurs.
Story Points: ---
Clone Of: 1244257
Environment:
Last Closed: 2015-08-13 05:02:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2015-07-29 09:59:11 EDT
This bug has been copied from bug #1244257 and has been proposed
to be backported to 6.7 z-stream (EUS).
Comment 6 errata-xmlrpc 2015-08-13 05:02:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1615.html

Note You need to log in before you can comment on or make changes to this bug.