Bug 1248054 - No sound after kernel upgrade to 4.1.2
No sound after kernel upgrade to 4.1.2
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2015-07-29 10:02 EDT by Victor A. Safronov
Modified: 2015-08-04 10:10 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-08-04 10:10:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Victor A. Safronov 2015-07-29 10:02:44 EDT
Description of problem:
No sound in all applications after system update, including kernel upgrade from 4.0.8 to 4.1.2. Sound appears if I boot back into 4.0.8

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Take my computer
2. Boot into 4.1.2 kernel
3. Try to play music

Actual results:
No sound.

Expected results:

Additional info:
Here is the systeminfo paste - http://paste.fedoraproject.org/249371/38177215/
I use analog output of internal (AMD) chip, which uses snd_hda_intel.
pavucontrol shows the music actually plays and the settings are fine, but there are no sound.
Comment 1 Striker Leggette 2015-07-29 11:45:16 EDT
Can you give the output of:

  $ lsmod | grep snd
Comment 2 Striker Leggette 2015-07-29 11:46:18 EDT
Also, do you not hear sound from only your music player?  Does sound work from YouTube?  Do you hear any sound when increasing the volume with the volume keys on your keyboard?  (should sound like a little 'pop')
Comment 3 Victor A. Safronov 2015-07-29 12:10:41 EDT
Of course I do not hear any sound, not only in music player. No system sound, no music in mp3 players, web browsers etc. 
here is a list of modules:

[vitek@vitek ~]$ lsmod | grep snd
snd_usb_audio         180224  2
snd_usbmidi_lib        32768  1 snd_usb_audio
snd_rawmidi            32768  1 snd_usbmidi_lib
snd_hda_codec_via      32768  1
snd_seq                73728  0
snd_hda_codec_generic    69632  1 snd_hda_codec_via
snd_hda_codec_hdmi     53248  1
snd_hda_intel          32768  6
snd_hda_controller     32768  1 snd_hda_intel
snd_seq_device         16384  2 snd_seq,snd_rawmidi
snd_hda_codec         139264  5 snd_hda_codec_hdmi,snd_hda_codec_via,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
snd_hwdep              16384  2 snd_usb_audio,snd_hda_codec
snd_pcm               114688  5 snd_usb_audio,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_controller
snd_timer              32768  2 snd_pcm,snd_seq
snd                    77824  29 snd_usb_audio,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_via,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec_generic,snd_usbmidi_lib,snd_hda_codec,snd_hda_intel,snd_seqdevice
soundcore              16384  2 snd,snd_hda_codec

I still suppose this bug is very selective to hardware.
I tried to analyze and compare dmesg output for both kernels, but didn't found any suitable thing.
I also checked System Settings -> Multimedia (I use KDE) for right settings, and they are there.
Comment 4 Victor A. Safronov 2015-07-29 12:14:47 EDT
Even more, when I first encountered a trouble, I used a proprietary graphics driver (kmod-nvidia). I understand that this driver shouldn't affect an AMD sound chip at all, but I swapped back to open source (just to be sure) and still no sound in 4.1.2, and it is magically comes back on 4.0.8
Comment 5 Paulo Fidalgo 2015-07-31 12:56:13 EDT
I have also runned in problems but in my cause I was not able to use the internal mic, after disconnecting the external one. I have tried to debug pulseaudio and alsa settings, even replacing them. After that I've boot a live cd (KDE spin to keep with the current spin I use) and got everything working right, it uses the 4.0.4 kernel version.
Comment 6 Paulo Fidalgo 2015-08-04 05:11:14 EDT
If needed there's an alsa-info output from my machine here: http://www.alsa-project.org/db/?f=c355667dd04dd0ffef8ee4830ea13b31806e0dae
Comment 7 Victor A. Safronov 2015-08-04 10:07:52 EDT
My problem does not exist in 4.1.3 kernel anymore.

Note You need to log in before you can comment on or make changes to this bug.