Bug 1248073 - kdevelop attach process missing
kdevelop attach process missing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdevelop (Show other bugs)
22
x86_64 Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-29 10:30 EDT by Andrey Amado
Modified: 2015-10-04 18:51 EDT (History)
9 users (show)

See Also:
Fixed In Version: kdevelop-4.7.1-10.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-04 18:51:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Do_not_use_function_returning_reference_to_temporary (1.29 KB, patch)
2015-09-24 04:44 EDT, Siddharth Sharma
no flags Details | Diff
Remove_ConvenientIterator_ref_usage_from_oldcpp_codebase (40.83 KB, message/rfc822)
2015-09-24 04:45 EDT, Siddharth Sharma
no flags Details
gdb kdevelop output (32.27 KB, text/plain)
2015-09-24 09:59 EDT, Dan Mossor [danofsatx]
no flags Details

  None (edit)
Description Andrey Amado 2015-07-29 10:30:28 EDT
Description of problem:
I find the option "Attach process" on  menu "Run" but no found.


Version-Release number of selected component (if applicable):
kdevelop-libs-4.7.1-1.fc22.x86_64
kdevelop-4.7.1-1.fc22.x86_64


How reproducible:

Open project, next find option on menu "Run" but no found for attach on process of system.


Actual results:
I can't attach one process of the system to kdevelop.

Expected results:
View option on menu "Run->Attach Process"

Additional info:
I found other references to it on arch and ubuntu.

https://bugs.archlinux.org/task/42757
https://bugs.launchpad.net/ubuntu/+source/kdevelop/+bug/1456956
Comment 1 Kevin Kofler 2015-07-30 05:51:05 EDT
That's why you should NEVER comment out BuildRequires. It's better to have the package not build at all until the missing BRs are imported, because that way you are sure to not forget to reenable them.
Comment 2 Rex Dieter 2015-07-30 09:29:00 EDT
what missing BuildRequires?  (I don't see anyting commented out in kdevelop.spec)
Comment 3 Kevin Kofler 2015-07-30 13:26:42 EDT
That's because I fixed it. The BR kde-workspace-devel was commented out, pending the partial reintroduction of kde-workspace for F22+. When that happened, the BR was not reenabled.
Comment 4 Fedora Update System 2015-07-30 13:30:27 EDT
kdevelop-4.7.1-7.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/kdevelop-4.7.1-7.fc23
Comment 5 Fedora Update System 2015-07-30 13:31:38 EDT
kdevelop-4.7.1-7.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/kdevelop-4.7.1-7.fc22
Comment 6 Andrey Amado 2015-07-30 14:06:56 EDT
Hi, thank for quickly response and patch, i installed the updates but on the moment to create new project show crash and I can't create or load project.
Attach the konsole output.

Legacy integer arithmetics implementation 
kdevelop(22243)/kdevplatform (shell) KDevelop::PluginController::loadPluginInternal: "El complemento «Implementación de Bazaar» no se puede cargar correctamente y ha sido desactivado.
Motivo: Bazaar is not installed (bzr executable not found)." 
kdevelop(22243)/kdeui (kdelibs): Attempt to use QAction "commit_or_finish_review" with KXMLGUIFactory! 
qrc:/qml/main.qml:23:1: QML Loader: Detectado bucle de enlace para la propiedad ësourceû
qrc:/qml/main.qml:23:1: QML Loader: Detectado bucle de enlace para la propiedad ësourceû
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 20 (X_GetProperty)
  Resource id:  0x3a00015
/bin/cat: /home/andreyamado/.kde/share/apps/kdevelop/sessions/{71260749-649d-4931-9cac-d7afe22ada76}/default.sh: No existe el fichero o el directorio
kdevelop(22243)/kdevplatform (shell) KDevelop::PluginController::loadPluginInternal: Unable to find a plugin named ' "" '! 
kdevelop(22243) KDevNinjaBuilderPlugin::KDevNinjaBuilderPlugin: Ninja plugin installed but ninja is not installed. 
kdevelop(22243)/kdevplatform (shell) KDevelop::PluginController::loadPluginInternal: "El complemento «Constructor de proyectos Ninja» no se puede cargar correctamente y ha sido desactivado.
Motivo: ." 
kdevelop(22243) KDevNinjaBuilderPlugin::KDevNinjaBuilderPlugin: Ninja plugin installed but ninja is not installed. 
kdevelop(22243)/kdevplatform (shell) KDevelop::PluginController::loadPluginInternal: "El complemento «Constructor de proyectos Ninja» no se puede cargar correctamente y ha sido desactivado.
Motivo: ." 
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 20 (X_GetProperty)
  Resource id:  0x3a00108
kdevelop(22243)/kdevplatform (shell) KDevelop::RunController::registerJob: non-killable job CMakeImportJob(0x1307df0) registered - this might lead to crashes on shutdown. 
Path::init: invalid/unsupported Path encountered: ""
Path::init: invalid/unsupported Path encountered: ""
Path::init: invalid/unsupported Path encountered: ""
KCrash: Application 'kdevelop' crashing...
KCrash: Attempting to start /usr/libexec/kde4/drkonqi from kdeinit
KCrash: Connect sock_file=/home/andreyamado/.kde/socket-serveradmin.vidamx.net/kdeinit4__0
QSocketNotifier: Invalid socket 7 and type 'Read', disabling...
QSocketNotifier: Invalid socket 13 and type 'Read', disabling...
QSocketNotifier: Invalid socket 16 and type 'Read', disabling...
QSocketNotifier: Invalid socket 31 and type 'Read', disabling...
QSocketNotifier: Invalid socket 43 and type 'Read', disabling...
QSocketNotifier: Invalid socket 25 and type 'Read', disabling...
kdevelop: Fatal IO error: client killed
DUContextData::m_childContexts There were items left on destruction: 2
TopDUContextData::m_problems There were items left on destruction: 3
DUContextData::m_uses There were items left on destruction: 49
TopDUContextData::m_usedDeclarationIds There were items left on destruction: 48
DUContextData::m_localDeclarations There were items left on destruction: 19
DUContextData::m_importers There were items left on destruction: 54
DUContextData::m_importedContexts There were items left on destruction: 55
pp_macro::formals There were items left on destruction: 31
pp_macro::definition There were items left on destruction: 403
Unable to start Dr. Konqi
[andreyamado@serveradmin build]$ Legacy integer arithmetics implementation 
drkonqi(22547): The specified process does not exist.
Comment 7 Kevin Kofler 2015-07-30 15:56:54 EDT
Are you sure you installed the correct version (the .fc22 one, not the .fc23 one)?
Comment 8 Andrey Amado 2015-07-30 16:00:38 EDT
yes, i sure.

kdevelop-devel-4.7.1-7.fc22.x86_64
kdevelop-libs-4.7.1-7.fc22.x86_64
kdevelop-4.7.1-7.fc22.x86_64
Comment 9 Andrey Amado 2015-07-30 18:40:48 EDT
I installed the packages on vm clean and work... the problem is my machine.. :( i report if found the problem.
Thank you.
Comment 10 Fedora Update System 2015-07-31 03:56:26 EDT
Package kdevelop-4.7.1-7.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kdevelop-4.7.1-7.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-12438/kdevelop-4.7.1-7.fc22
then log in and leave karma (feedback).
Comment 11 Andrey Amado 2015-07-31 19:02:03 EDT
I upgrade my clean machine to testing and present same problems with new project "Standar->terminal", with new project "QT->graphical" work property.

I found a workaround for my issue, i open kdevelop with out any project, next i import the project and repeat press the button "stop all" and the task show on the progress bar stop and my project can import correctly.

I search more about the threads on the init process of kdevelop and inform if  ia can found any.
Comment 12 Andrey Amado 2015-07-31 19:11:11 EDT
well, I was disabled the "analyzer background" and is some stable, but i activate its and instant crash. i think the problem is related with libthread  

Application: KDevelop (kdevelop), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f892d721900 (LWP 26178))]

Thread 11 (Thread 0x7f8900979700 (LWP 26179)):
#0  0x00007f892859c540 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f892683ab5a in QTWTF::TCMalloc_PageHeap::scavengerThread() () from /lib64/libQtScript.so.4
#2  0x00007f892683ab89 in QTWTF::TCMalloc_PageHeap::runScavengerThread(void*) () from /lib64/libQtScript.so.4
#3  0x00007f8928597555 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f8927a31b9d in clone () from /lib64/libc.so.6

Thread 10 (Thread 0x7f887ef5f700 (LWP 26181)):
#0  0x00007f892859c8e9 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f8928826ff4 in QWaitCondition::wait(QMutex*, unsigned long) () from /lib64/libQtCore.so.4
#2  0x00007f8926c25586 in KDevelop::DUChainPrivate::CleanupThread::run() () from /lib64/libkdevplatformlanguage.so.8
#3  0x00007f8928826aac in QThreadPrivate::start(void*) () from /lib64/libQtCore.so.4
#4  0x00007f8928597555 in start_thread () from /lib64/libpthread.so.0
#5  0x00007f8927a31b9d in clone () from /lib64/libc.so.6

...

Thread 6 (Thread 0x7f884f7be700 (LWP 26228)):
[KCrash Handler]
#6  0x00007f8861c5f270 in QHash<KDevelop::IndexedString, QHashDummyValue>::findNode(KDevelop::IndexedString const&, unsigned int*) const () from /lib64/libkdev4cppduchain.so
#7  0x00007f8861c8af9a in CppPreprocessEnvironment::merge(Cpp::EnvironmentFile const*, bool) () from /lib64/libkdev4cppduchain.so
#8  0x00007f8861f2f119 in PreprocessJob::sourceNeeded(QString&, rpp::Preprocessor::IncludeType, int, bool) () from /usr/lib64/kde4/kdevcpplanguagesupport.so
#9  0x00007f886175923c in rpp::pp::handle_include(bool, rpp::Stream&, rpp::Stream&) () from /lib64/libkdev4cpprpp.so
#10 0x00007f886175d4ff in rpp::pp::handle_directive(unsigned int, rpp::Stream&, rpp::Stream&) () from /lib64/libkdev4cpprpp.so
#11 0x00007f886175da8e in rpp::pp::operator()(rpp::Stream&, rpp::Stream&) () from /lib64/libkdev4cpprpp.so
#12 0x00007f886175de07 in rpp::pp::processFileInternal(QString const&, QByteArray const&, QVector<unsigned int>&) () from /lib64/libkdev4cpprpp.so
#13 0x00007f886175e1e5 in rpp::pp::processFile(QString const&, QByteArray const&) () from /lib64/libkdev4cpprpp.so
#14 0x00007f8861f319c6 in PreprocessJob::run() () from /usr/lib64/kde4/kdevcpplanguagesupport.so
#15 0x00007f8861f25afe in CPPParseJob::parseForeground() () from /usr/lib64/kde4/kdevcpplanguagesupport.so
#16 0x00007f8861f2fb49 in PreprocessJob::sourceNeeded(QString&, rpp::Preprocessor::IncludeType, int, bool) () from /usr/lib64/kde4/kdevcpplanguagesupport.so
#17 0x00007f886175923c in rpp::pp::handle_include(bool, rpp::Stream&, rpp::Stream&) () from /lib64/libkdev4cpprpp.so
#18 0x00007f886175d4ff in rpp::pp::handle_directive(unsigned int, rpp::Stream&, rpp::Stream&) () from /lib64/libkdev4cpprpp.so
#19 0x00007f886175da8e in rpp::pp::operator()(rpp::Stream&, rpp::Stream&) () from /lib64/libkdev4cpprpp.so
#20 0x00007f886175de07 in rpp::pp::processFileInternal(QString const&, QByteArray const&, QVector<unsigned int>&) () from /lib64/libkdev4cpprpp.so
#21 0x00007f886175e1e5 in rpp::pp::processFile(QString const&, QByteArray const&) () from /lib64/libkdev4cpprpp.so
#22 0x00007f8861f319c6 in PreprocessJob::run() () from /usr/lib64/kde4/kdevcpplanguagesupport.so
#23 0x00007f8861f25afe in CPPParseJob::parseForeground() () from /usr/lib64/kde4/kdevcpplanguagesupport.so
#24 0x00007f8861f2fb49 in PreprocessJob::sourceNeeded(QString&, rpp::Preprocessor::IncludeType, int, bool) () from /usr/lib64/kde4/kdevcpplanguagesupport.so
#25 0x00007f886175923c in rpp::pp::handle_include(bool, rpp::Stream&, rpp::Stream&) () from /lib64/libkdev4cpprpp.so
#26 0x00007f886175d4ff in rpp::pp::handle_directive(unsigned int, rpp::Stream&, rpp::Stream&) () from /lib64/libkdev4cpprpp.so
#27 0x00007f886175da8e in rpp::pp::operator()(rpp::Stream&, rpp::Stream&) () from /lib64/libkdev4cpprpp.so
#28 0x00007f886175de07 in rpp::pp::processFileInternal(QString const&, QByteArray const&, QVector<unsigned int>&) () from /lib64/libkdev4cpprpp.so
#29 0x00007f886175e1e5 in rpp::pp::processFile(QString const&, QByteArray const&) () from /lib64/libkdev4cpprpp.so
#30 0x00007f8861f319c6 in PreprocessJob::run() () from /usr/lib64/kde4/kdevcpplanguagesupport.so
#31 0x00007f8861f25afe in CPPParseJob::parseForeground() () from /usr/lib64/kde4/kdevcpplanguagesupport.so
#32 0x00007f8861f2fb49 in PreprocessJob::sourceNeeded(QString&, rpp::Preprocessor::IncludeType, int, bool) () from /usr/lib64/kde4/kdevcpplanguagesupport.so
#33 0x00007f886175923c in rpp::pp::handle_include(bool, rpp::Stream&, rpp::Stream&) () from /lib64/libkdev4cpprpp.so
#34 0x00007f886175d4ff in rpp::pp::handle_directive(unsigned int, rpp::Stream&, rpp::Stream&) () from /lib64/libkdev4cpprpp.so
#35 0x00007f886175da8e in rpp::pp::operator()(rpp::Stream&, rpp::Stream&) () from /lib64/libkdev4cpprpp.so
#36 0x00007f886175de07 in rpp::pp::processFileInternal(QString const&, QByteArray const&, QVector<unsigned int>&) () from /lib64/libkdev4cpprpp.so
#37 0x00007f886175e1e5 in rpp::pp::processFile(QString const&, QByteArray const&) () from /lib64/libkdev4cpprpp.so
#38 0x00007f8861f319c6 in PreprocessJob::run() () from /usr/lib64/kde4/kdevcpplanguagesupport.so
#39 0x00007f8928caa712 in ThreadWeaver::JobRunHelper::runTheJob(ThreadWeaver::Thread*, ThreadWeaver::Job*) () from /lib64/libthreadweaver.so.4
#40 0x00007f8928caa91e in ThreadWeaver::Job::execute(ThreadWeaver::Thread*) () from /lib64/libthreadweaver.so.4
#41 0x00007f8928cac61b in ThreadWeaver::JobCollectionJobRunner::execute(ThreadWeaver::Thread*) () from /lib64/libthreadweaver.so.4
#42 0x00007f8928ca9feb in ThreadWeaver::Thread::run() () from /lib64/libthreadweaver.so.4
#43 0x00007f8928826aac in QThreadPrivate::start(void*) () from /lib64/libQtCore.so.4
#44 0x00007f8928597555 in start_thread () from /lib64/libpthread.so.0
#45 0x00007f8927a31b9d in clone () from /lib64/libc.so.6
Comment 13 Fedora Update System 2015-08-10 05:54:34 EDT
kdevelop-4.7.1-7.fc23 has been pushed to the Fedora 23 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Siddharth Sharma 2015-09-24 04:44 EDT
Created attachment 1076398 [details]
Do_not_use_function_returning_reference_to_temporary

Patch 1
Comment 15 Siddharth Sharma 2015-09-24 04:45 EDT
Created attachment 1076399 [details]
Remove_ConvenientIterator_ref_usage_from_oldcpp_codebase

Patch 2
Comment 17 Siddharth Sharma 2015-09-24 04:52:36 EDT
Please pull in these patches and fix it, even the update in master branch of fedora does not fix this issue.
Comment 18 Kevin Kofler 2015-09-24 05:19:59 EDT
To be clear, are you saying that these are the fixes for the crashes in kdevelop-4.7.1-7.fc22?
Comment 19 Siddharth Sharma 2015-09-24 08:53:55 EDT
(In reply to Kevin Kofler from comment #18)
> To be clear, are you saying that these are the fixes for the crashes in
> kdevelop-4.7.1-7.fc22?

yes
Comment 20 Dan Mossor [danofsatx] 2015-09-24 09:59 EDT
Created attachment 1076554 [details]
gdb kdevelop output

Complete log of 'gdb kdevelop' with kdevelop-4.7.1-7.fc22.x86_64
Comment 21 Kevin Kofler 2015-09-24 19:16:11 EDT
The regression (confirmed to also affect F23) is now tracked as bug #1266259.
Comment 22 Fedora Update System 2015-09-24 20:18:57 EDT
kdevelop-4.7.1-10.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-241fe028cb
Comment 23 Andrey Amado 2015-09-24 21:05:05 EDT
Hi, I tested the last patches and work, I can open the project and compile successful.

Thanks
Comment 24 Fedora Update System 2015-09-26 20:38:06 EDT
kdevelop-4.7.1-10.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update kdevelop'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-241fe028cb
Comment 25 Fedora Update System 2015-10-04 18:51:32 EDT
kdevelop-4.7.1-10.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.