This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1248078 - rsyslog log rotation fails due to incorrect selinux labels on /etc/logrotate.d/syslog
rsyslog log rotation fails due to incorrect selinux labels on /etc/logrotate....
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rsyslog-docker (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Eliska Slobodova
atomic-bugs@redhat.com
Brian (bex) Exelbierd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-29 10:37 EDT by Stephen Tweedie
Modified: 2015-11-19 18:28 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 18:28:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Tweedie 2015-07-29 10:37:09 EDT
Description of problem:
With the rsyslog SPC installed, log rotation works fine when invoked directly from the command line, but fails from crond, leaving an error in admin email:

From: Anacron <root@rhel-cloud.localdomain>
To: root@rhel-cloud.localdomain
Subject: Anacron job 'cron.daily' on rhel-cloud.localdomain

/etc/cron.daily/logrotate:

error: failed to open config file syslog: Permission denied
error: found error in file syslog, skipping

And indeed, the syslog logrotate file is installed with incorrect selinux labels (unsurprisingly, as the atomic INSTALL script doesn't set the label):

# ls -lZ /etc/logrotate.d
-rw-r--r--. root root system_u:object_r:etc_t:s0       chrony
-rw-r--r--. root root system_u:object_r:etc_t:s0       httpd
-rw-r--r--. root root system_u:object_r:etc_t:s0       ppp
-rw-r--r--. root root system_u:object_r:etc_t:s0       subscription-manager
-rw-r--r--. root root system_u:object_r:unlabeled_t:s0 syslog
-rw-r--r--. root root system_u:object_r:etc_t:s0       up2date
-rw-r--r--. root root system_u:object_r:etc_t:s0       wpa_supplicant
-rw-r--r--. root root system_u:object_r:etc_t:s0       yum


Version-Release number of selected component (if applicable):
rhel7/rsyslog:7.1-5

How reproducible:
100%

Steps to Reproduce:
1. atomic install rhel7/rsyslog
2. ls -lZ /etc/logrotate.d/
or
2. Wait 24 hours and watch for email to the admin
Comment 5 errata-xmlrpc 2015-11-19 18:28:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2490.html

Note You need to log in before you can comment on or make changes to this bug.