Bug 124812 - Taskbar freezes (no response to mouse clicks) with 3 to 7 windows open
Summary: Taskbar freezes (no response to mouse clicks) with 3 to 7 windows open
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase   
(Show other bugs)
Version: 2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-30 16:55 UTC by Catherine Heyrendt
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-04 15:24:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Catherine Heyrendt 2004-05-30 16:55:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
When I have several windows open, the taskbar sometimes freezes. It
does not respond to mouse clicks, although alt+tab still allows you to
navigate between the different windows. What happens next is that
either I need to log out and back in, OR the taskbar starts working
again spontaneously after a while (it starts working in a delayed
manner then resumes its normal speed). 
At the time of the freeze, the windows that are open vary between 3
and 7. They are usually Lyx, Mozilla, Kwrite, sometimes openoffice and
pine. This freezing of the taskbar never happened when I was doing
similar things with Fedora 1.

Version-Release number of selected component (if applicable):
kdebase-3.2.2-4

How reproducible:
Sometimes

Steps to Reproduce:
1. Using the KDE desktop, open several windows (several combinations
can do it, in my case it's usually Lyx, mozilla, kwrite, maybe with
openoffice or pine)
2. After a while, the taskbar freezes and no longer allows you to
navigate from one window to the next.
    

Actual Results:  The taskbar froze.

Expected Results:  The taskbar should have allowed me to keep moving
from one window to the next.

Additional info:

This never happened under Fedora 1.

Comment 1 Ngo Than 2004-05-31 17:36:43 UTC
with your steps, i have tried to reproduce this problem on my machine
with FC2, but it works fine for me here.

which qt version did you install on your machine?


Comment 2 Catherine Heyrendt 2004-05-31 17:49:07 UTC
I'm using qt-3.3.2-2

Comment 3 Ngo Than 2004-05-31 18:32:25 UTC
I have seen some reports about this problem before and it seems to be
fixed after the new qt-3.3.2 has been updated.

it's not easy to fix this problem if it's not always reproduceable!

Could you please check again that you really have qt-3.3.2 running on
your machine?



Comment 4 Catherine Heyrendt 2004-05-31 19:02:24 UTC
Yes, I double checked and my computer consistantly tells me that it is
running qt-3.3.2-2 
Thanks a lot for trying to fix it!

Comment 5 Ben Smith 2004-06-03 05:48:15 UTC
Things I would wonder are whether you have the screensaver enabled 
or if you have your panel set to auto-hide.  Our machine(s) that had 
this the worst seemed to have both of these enabled. 

Comment 6 Dennixx 2004-06-03 19:12:49 UTC
I seem to have about the same problem here.

I can move the mouse, but when I click something it doesn't respond...
keyboard shortcuts still work. after a few seconds, all my
mouse-actions are executed and everything works fine after that... for
a while...

It looks to me like it's being triggered by mozilla, but I'm not 100%
sure of that....

Before FC2 I ran RH9, and didn't have the problem there. I installed
FC2 clean, I didn't upgrade.

%  rpm -q qt
qt-3.3.2-2


Comment 7 Catherine Heyrendt 2004-06-03 22:36:40 UTC
I don't have my panel set to auto-hide. I don't really use a
screensaver but my screen is set to go black after a few minutes.

The taskbar freeze happened to me again twice in the last two days.
The first time I had 3 items in the taskbar: Kwrite + Lyx + Lyx DVI
preview. The second time I had 4: openoffice + Lyx + Lyx DVI preview +
KGhostview displaying a PDF document.

In both cases, I could move the mouse arrow, but the clicks on the
taskbar didn't do anything. I used keyboard shortcuts (alt+tab) to
navigate between my windows, and after a while the taskbar started to
respond again.

Comment 8 Catherine Heyrendt 2004-06-04 16:06:27 UTC
I get about one taskbar freeze a day (i.e. one for about 6h to 7h on
the computer).
Today it involved: Lyx, Mozilla, openoffice, pine, gtkpod and grip.
The "recovery" was slightly faster than usual, taking around 15-20
seconds.

Comment 9 Terry Davis 2004-07-09 15:08:11 UTC
I have the same behavior.  Here are some quick facts:
kdebase-3.2.2-4
qt-3.3.2-2

- I have 6 virtual desktops
- It happens with the following applets, sometimes more: clock,
logout/lock

Catherine pretty much describes the same behavior that I see.


Comment 10 Ngo Than 2004-07-13 09:17:48 UTC
It's strange i still cannot reproduce this problem here.

does this problem still show up if you remove klipper applet?

Comment 11 Terry Davis 2004-07-13 13:43:38 UTC
I want to say that I saw the behavior without klipper as well but I am
going to remove the applet just to be sure.

Comment 12 Catherine Heyrendt 2004-07-15 20:48:06 UTC
I have just removed the klipper applet, and will report back in a
couple of days. 

It would be great if it were that, because the frequency of the
freezes increased quite a lot recently - from every 4-5h to every 15mn
or so (with 1 to 3 windows open, mainly Lyx, Lyx DVI preview and pine). 

Using alt+tab to change windows is a way to keep working through the
freezes, although it isn't ideal.

Comment 13 Terry Davis 2004-07-19 13:39:48 UTC
I removed klipper and the problem hasn't occurred.  I will report back
if I find otherwise but that looks like the problem.



Comment 14 Catherine Heyrendt 2004-07-19 18:11:27 UTC
My taskbar freezes have stopped too, now that I have removed clipper.
IT seems that this was causing the problem.

Comment 15 Dennixx 2004-07-26 18:07:13 UTC
Also for me the removal of klipper seems to have helped.
I was starting to notice that the freezes occured sometimes when I was
selecting some text...

Comment 16 Doncho Gunchev 2004-09-27 22:34:30 UTC
I updated my home pc to FC3t2 (from FC1). With FC1 and my personal
account - no problems at all and ever, but two friends (with accounts
on my pc) had. Now, when I installed FC3t2 I very rarely have 2-3
second freezes. My friend has FC2 and sometimes mozilla freezes for
5-10 seconds with KDE (we never tested GNOME) and sometimes (rarely)
with other apps. I'll try removing klipper now.

Comment 17 Ngo Than 2004-11-04 15:24:48 UTC
it's not reproduceable in FC3 and with KDE-3.3.1 for FC2.


Note You need to log in before you can comment on or make changes to this bug.