Bug 124813 - /proc/1/environ truncates HOME to OME
Summary: /proc/1/environ truncates HOME to OME
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: sysvinit   
(Show other bugs)
Version: 1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-30 17:23 UTC by Stephen Walton
Modified: 2014-03-17 02:45 UTC (History)
1 user (show)

Fixed In Version: 2.85-28
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-03 14:48:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephen Walton 2004-05-30 17:23:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
This is actually from the apcupsd-users mailing list.  Execute as root
/proc/1/environ truncates HOME to OME for some reason.  This can mess
up scripts at init time which need a correct HOME directory.

Version-Release number of selected component (if applicable):
SysVinit-2.85-5

How reproducible:
Always

Steps to Reproduce:
1.tr '\0' '\n' < /proc/1/environ

The output will read
 
OME=/
TERM=linux

instead of the correct
 
HOME=/
TERM=linux
   

Actual Results:  Truncated HOME to OME

Expected Results:  HOME should have been printed.

Additional info:

Comment 1 Bill Nottingham 2004-06-01 05:07:30 UTC
Actually, I'm not seeing HOME set at all in init's environment here.

Comment 2 Stephen Walton 2004-06-01 18:51:26 UTC
Odd.  I see OME in init's environment on all of my FC1 systems, both
those installed from the original FC1 CDs and then kept up to date via
Yum and those which I installed from the KRUD distribution.  In any
event, if I understood the point of the post to apcupsd-users, HOME
needs to be set in init's environment for apcupsd, at least, to work
properly.  I was going to link to the original post here, but the
apcupsd-users mailing list archive on sourceforge seems not to have
been updated since May 28.

Comment 3 Bill Nottingham 2004-06-03 14:40:04 UTC
While I'm working into integrating it in the head branch, care to try
the patch in bug 125172?

It should fix it for you.

Comment 4 Bill Nottingham 2004-06-03 14:48:29 UTC
Should be fixed in 2.85-28.

Comment 5 Stephen Walton 2004-06-03 23:22:28 UTC
The suggested patch fixes the problem, thanks.

Comment 6 David Lawrence 2007-06-22 02:18:34 UTC
Package name is now sysvinit in latest Fedora.


Note You need to log in before you can comment on or make changes to this bug.